Results 1 to 2 of 2

Thread: Z16XE help.

  
  1. #1
    Status
    Offline
    AaronSxi's Avatar
    AOC Newbie
    Join Date
    Jan 2009
    Posts
    33
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Z16XE help.

    hello..

    my car sounds like a tractor and is burning alot of oil making me think the valve stem seals were at fault.. got a fault code the other day of P0170 - Fuel trim..

    previously when it started tapping i just topped it up with oil and it went away.. although last night after clearing the code it came back up again and the car started tapping very loudly.. so

    i just checked the oil level expecting it to be empty but its full..

    the car is dumping loads of fuel in on idle and when revving.. couldn't be tapping any louder.. its a 52 plate just below 50k..

    seeing that the oil level is still high and its started tapping has confused me now.. i kno the above fault code can be one of a few things from coil pack, mass air flow or lambda sensor..

    originally when the code came up i thought it might be the steam seals leaking oil onto the lambda sensor which has killed it..

    but now its tapping but hasnt lost any oil

    anyone got any ideas??

  2. #2
    Status
    Offline
    AaronSxi's Avatar
    AOC Newbie
    Join Date
    Jan 2009
    Posts
    33
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    took it out for a quick drive today.. almost no power between 1000 - 2000rpm very loud tapping and rev increase on declutching..

Similar Threads

  1. z16xe please help!!!
    By momak78 in forum Electrical
    Replies: 2
    Last Post: 26-01-2010, 16:44
  2. Z16XE Again...Getting Better Tho!!
    By mick84 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 2
    Last Post: 17-04-2008, 23:25

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •