Results 1 to 5 of 5

Thread: z20 let boost issues

  
  1. #1
    Status
    Offline
    banks124's Avatar
    AOC Regular
    Join Date
    Feb 2009
    Posts
    139
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Question z20 let boost issues

    hey guys ive fitted a z20 let into my astra coupe. its all running sweet all bar a slight blow from the pre-cat atm.(ive gotta do it tomorow)

    ive fitted a boost gauge to it. it all runs off the throttle bady. ive disconnected all the pipes at the back and run everthing from the throttle ody like it said on thread in here.

    its running 9 psi of boost which it holds. i will go upto 10 and sometimes fluctuate between 9 and 7.

    my mate had a gsi which wen standard pull'd 11 psi

    is mine ok? any ideas?
    maybe boost leak or?

    thanks in advance boys
    if your not livin on the edge u take up to much room


  2. #2
    Status
    Offline
    banks124's Avatar
    AOC Regular
    Join Date
    Feb 2009
    Posts
    139
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    any advice please?
    if your not livin on the edge u take up to much room


  3. #3
    Status
    Offline
    andys sri-t's Avatar
    AOC Obsessed
    Join Date
    Aug 2008
    Posts
    1,514
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    9 psi standard is good mate
    never drink and drive .you might spill your drink
    **** n/a turbo is the way

  4. #4
    Status
    Offline
    banks124's Avatar
    AOC Regular
    Join Date
    Feb 2009
    Posts
    139
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    thats ok then my mats was 11 i didnt kno if i was loosin boost thanks mate
    if your not livin on the edge u take up to much room


  5. #5
    Status
    Offline
    DCA's Avatar
    AOC Fanatic
    Join Date
    Mar 2008
    Posts
    523
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    sounds fine bud

Similar Threads

  1. Boost Issues
    By bernie197401 in forum Astra Discussion & Chat
    Replies: 4
    Last Post: 18-07-2012, 21:06
  2. Help or the GSI gets it!!!!! Boost issues!!!
    By gsibell in forum Turbo Petrol Engines inc. Transmissions
    Replies: 15
    Last Post: 06-09-2009, 21:45

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •