Results 1 to 10 of 10

Thread: Z18xe fuel pressure dropping off

  
  1. #1
    Status
    Offline
    ntsri's Avatar
    AOC Newbie
    Join Date
    Jan 2007
    Posts
    23
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Z18xe fuel pressure dropping off

    hi just wondering if anyone else has had this problem fuel pressure is fine and stays at the normal 3.8 BAR until i get over 5500rpm then it drops off to about 2.8-3.0 tried another pump still the same about to get a pressure regulator just seeing if anyone else got any ideas. keep getting P0170 code Lean Exhaust!

    cheers

  2. #2
    Status
    Offline
    micky taylor 888's Avatar
    AOC Regular
    Join Date
    Jul 2008
    Posts
    245
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    one of 4 things mate, air flow meter, 02 sensor pre cat, 02 sensor post cat or engine ecu iv had that code many times before at work, really need to see wots going on on the data list though to check the readings

  3. #3
    Status
    Offline
    ntsri's Avatar
    AOC Newbie
    Join Date
    Jan 2007
    Posts
    23
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    ive checked all the readings for lambdas and afm all seem fine but just to check do you know what they should be reading at? its hard to find out what the readings should be unless from the dealer

    cheers

  4. #4
    Status
    Offline
    micky taylor 888's Avatar
    AOC Regular
    Join Date
    Jul 2008
    Posts
    245
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    its hard to say mate, without having it on tech 2 and seeing it were just guessing, id still be thinking first 02 sensor mate

  5. #5
    Status
    Offline
    ntsri's Avatar
    AOC Newbie
    Join Date
    Jan 2007
    Posts
    23
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    it was only changed a few months ago and so was air mass ive found a pressure regulator so will try this when it comes and see if any improvement the problem i have is that it is obviously leaning off when the pressure drops and bringing the fault code up but when running below 5500rpm it actually slightly running rich according to the lambda it has been doin this since i had it remapped at regal about a year and half ago but never got round to doin anything about it as i wasnt goin back down south for another sh*t service getting it remapped hopefully soon at chippeduk bromsgrove just wanted this fuelling sorted out b4 hand

  6. #6
    Status
    Offline
    badboysracing69's Avatar
    AOC Regular
    Join Date
    Nov 2006
    Posts
    228
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Try an air mass meter. Tech 2 reading can be within tolorence but it could still be knackered. I had it before
    Cheap Vaux mech at your service in Herts/cambs

  7. #7
    Status
    Offline
    micky taylor 888's Avatar
    AOC Regular
    Join Date
    Jul 2008
    Posts
    245
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    let me know if you need any bits mate, got an ecu somewere

  8. #8
    Status
    Offline
    micky taylor 888's Avatar
    AOC Regular
    Join Date
    Jul 2008
    Posts
    245
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by ntsri View Post
    it was only changed a few months ago and so was air mass ive found a pressure regulator so will try this when it comes and see if any improvement the problem i have is that it is obviously leaning off when the pressure drops and bringing the fault code up but when running below 5500rpm it actually slightly running rich according to the lambda it has been doin this since i had it remapped at regal about a year and half ago but never got round to doin anything about it as i wasnt goin back down south for another sh*t service getting it remapped hopefully soon at chippeduk bromsgrove just wanted this fuelling sorted out b4 hand
    also check voltage as well as air mass

  9. #9
    Status
    Offline
    ntsri's Avatar
    AOC Newbie
    Join Date
    Jan 2007
    Posts
    23
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    cheers will do also by any chance have any 1 had fault code in ABS C0256 torque reduction or pedal position motor comes on and off every now and again

  10. #10
    Status
    Offline
    micky taylor 888's Avatar
    AOC Regular
    Join Date
    Jul 2008
    Posts
    245
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by ntsri View Post
    cheers will do also by any chance have any 1 had fault code in ABS C0256 torque reduction or pedal position motor comes on and off every now and again
    yeah throttle body or ecu

Similar Threads

  1. what to set z18xe fuel pressure at
    By RED~GRIFFIN in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 4
    Last Post: 28-01-2011, 18:13
  2. Tyre pressure dropping quick
    By rik_t in forum Chassis
    Replies: 1
    Last Post: 17-01-2007, 23:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •