Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: lagging engine! mk4

  
  1. #1
    Status
    Offline
    spitex's Avatar
    AOC Newbie
    Join Date
    Feb 2009
    Posts
    5
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    lagging engine! mk4

    At first i'll say sorry for bad english, as i am from norway :P

    But i have a problem with my astra mk4 hatch! it's a x14xe engine.
    when i put the "pedal to the metal" mostly in second and third gear, it's a bit laggy. Sometimes it's smooth and somtimes it laggs like hell.. what do you think the problem can be? air mass flow meter? lambda senson? If someone have experienced this before i'll be glad for som tips

    thanks

  2. #2
    Status
    Offline
    spitex's Avatar
    AOC Newbie
    Join Date
    Feb 2009
    Posts
    5
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    no one? anything?

  3. #3
    Status
    Offline
    mfivebmw's Avatar
    AOC Fanatic
    Join Date
    Aug 2007
    Posts
    760
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Wecome to the Club,

    has any warning lights come on,

    try unplugging the air flow meter.


    Dave

  4. #4
    Status
    Offline
    spitex's Avatar
    AOC Newbie
    Join Date
    Feb 2009
    Posts
    5
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    thanks sorry for dumb question :P but where is the airflowmeter? tought i knew it, but seems like it is the air temperatursensor :P

    the engine light comes on some times, but dissapear after a minute or to. havent come on in a long time now tough.

  5. #5
    Status
    Offline
    Toms1989's Avatar
    Soft Top VTEC :)
    Join Date
    Dec 2007
    Posts
    11,356
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    1.4 16v's don't have an airflow meter mate

    They have an air temperature sensor

    Probably your best bet is to remove the throttle body, give it a really good clean as they have a habbit of getting clogged up with grease and oily stuff ( due to the crank case breather )

    Whilst you are there you may aswell take out the idle control valve and give that a really good clean aswell, this should help responsiveness and let the air flow more freely
    FULL Black Leather Heated coupe interior for sale! £200!!!
    Click Here

  6. #6
    Status
    Offline
    Toms1989's Avatar
    Soft Top VTEC :)
    Join Date
    Dec 2007
    Posts
    11,356
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    Oh and just for good measure here is the idle control valve inside the red circle, held on by two screws and thats what the throttle body will look like when its clean too

    FULL Black Leather Heated coupe interior for sale! £200!!!
    Click Here

  7. #7
    Status
    Offline
    spitex's Avatar
    AOC Newbie
    Join Date
    Feb 2009
    Posts
    5
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    thaks i did clean the throttle body a week ago, but the problem was still there. I'll try to clean the idel controll valve to

  8. #8
    Status
    Offline
    jam's Avatar
    AOC Gold Member
    Join Date
    Apr 2005
    Location
    Tamworth, Staffordshire
    Posts
    11,695
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Follow jam On Twitter
    When was it last serviced and has it only started to do this recently?

    Any mods to the car?
    Its a jam thing

    Haec credam a deo pio, a deo justo, a deo scito?



  9. #9
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    will be better cleaning out the EGR valve than the ICV but may as well clean both

    do the paperclip test too to see what codes flash up

    http://www.astraownersclub.com/vb/sh...69&postcount=4
    (ignore the first part of the link as its taken from another thread)

  10. #10
    Status
    Offline
    spitex's Avatar
    AOC Newbie
    Join Date
    Feb 2009
    Posts
    5
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i'll try to clean both valves tomorrow after work thanks guys

Page 1 of 2 12 LastLast

Similar Threads

  1. mk4 lagging problem
    By guesty1310 in forum Astra Discussion & Chat
    Replies: 0
    Last Post: 01-07-2011, 11:20
  2. Replies: 39
    Last Post: 13-08-2010, 16:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •