Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Help Needed Please 1.8 SRi Problem

  
  1. #1
    Status
    Offline
    Kelk's Avatar
    AOC Newbie
    Join Date
    Apr 2009
    Posts
    63
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Angry Help Needed Please 1.8 SRi Problem

    ive got an Mk 4 Astra 1.8 SRi 52 reg

    On monday the car started juddering & the engine management light came on.

    i got the AA out & they said it was miss fireing on all 4 cylinders & found that the coil pack was cracked,

    so ive since changed that & had the EML cleared.

    now i have the problem of the EML light being on & not being able to drive over 65 MPH & cant go above 3500 revs & the sound of miss fireing.

    since all this i have replaced the Air flow meter, crank sensor & cam sensor aswell as spark plugs. I still have the same problem & its stressing me out big time

    My thinking might be that the AFM was a 2nd hand one so dont know if it's that which might be also faulty like my original

    any help will be great ty.

  2. #2
    Status
    Offline
    Kaycee7's Avatar
    AOC Newbie
    Join Date
    May 2009
    Posts
    10
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Might sound really stupid, and im not a mechanic of any kind, but i had a similar problem, mine started playing up a while bk on the motorway and the engine management light came on which kick started the engine management system. What happens is it triggers 'limp home' mode when u reach a certain speed, which takes your acceleration away until you go back down to a more suitable speed - then gives you it bk. I went around the houses trying to find the problem, and in the end it was kind of embarrassing, because it turned out it was because it was low on oil. I'm assuming you will have checked your oil, but if u havent, i would do, because the mk4 is notorious for using oil fast!

  3. #3
    Status
    Offline
    Keif's Avatar
    Going Topless!
    Join Date
    Jun 2003
    Drives
    Astra 1.8 Twintop, Lotus Carlton, Meriva VXR and Nova
    Posts
    11,742
    Mentioned in
    1 Post(s)
    Quoted
    11 Post(s)
    Have you any dash warning lights on? I'm assuming so, as it's in limp mode.

    Do the Pedal test (do a search) and find out what's at fault then work from there.

  4. #4
    Status
    Offline
    Kelk's Avatar
    AOC Newbie
    Join Date
    Apr 2009
    Posts
    63
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    the EML light is on, erm sound daft but what's a pedal test lol, any links?

  5. #5
    Status
    Offline
    Keif's Avatar
    Going Topless!
    Join Date
    Jun 2003
    Drives
    Astra 1.8 Twintop, Lotus Carlton, Meriva VXR and Nova
    Posts
    11,742
    Mentioned in
    1 Post(s)
    Quoted
    11 Post(s)
    Quote Originally Posted by Keif View Post
    Do a search
    http://www.astraownersclub.com/vb/se...archid=3220627

  6. #6
    Status
    Offline
    Kelk's Avatar
    AOC Newbie
    Join Date
    Apr 2009
    Posts
    63
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Link dont work pal

  7. #7
    Status
    Offline
    SRI-T Keithy's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    5,745
    Mentioned in
    1 Post(s)
    Quoted
    0 Post(s)
    For those that arent aware
    upto 2000 models - use the good old paperclip method:http://www.astraownersclub.com/vb/sh...69&postcount=4
    2000 models onwards - use the both pedal method: http://www.astraownersclub.com/vb/sh...78&postcount=2


    Fault codes http://www.astraownersclub.com/vb/sh...d.php?t=174728

    White is the new Black

    FARMYARD TUNING

    LEH IS THE FUTURE

  8. #8
    Status
    Offline
    Kelk's Avatar
    AOC Newbie
    Join Date
    Apr 2009
    Posts
    63
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Done the pedal test and comes up with the following:

    0301 - Cylinder 1 Missfire
    0304 - Cylinder 4 Missfire
    0100 - Mass or Volume Air Flow Circuit Malfunction
    0340 - Camshaft Position Sensor Circuit Malfunction
    1555 - Throttle Position Sensor Circuit Malfunction
    0303 - Cylinder 3 Missfire



  9. #9
    Status
    Offline
    Kelk's Avatar
    AOC Newbie
    Join Date
    Apr 2009
    Posts
    63
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    ive cleared all the faults using the local garage's fault machine for free, but then to be told it could be a possible valve spring!!!! Not happy as its a full strip down :'(

  10. #10
    fdrightup
    fdrightup's Avatar
    Quote Originally Posted by Kelk View Post
    ive cleared all the faults using the local garage's fault machine for free, but then to be told it could be a possible valve spring!!!! Not happy as its a full strip down :'(
    are you sure its a valve spring?

Page 1 of 2 12 LastLast

Similar Threads

  1. Sub And Amp Problem Help Needed
    By ASTRA-BOY in forum ICE Mk4|G
    Replies: 5
    Last Post: 07-06-2005, 14:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •