Results 1 to 3 of 3

Thread: emissions light

  
  1. #1
    Status
    Offline
    Scott D's Avatar
    AOC Fanatic
    Join Date
    Mar 2007
    Posts
    385
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    emissions light

    I filled up at Tesco on Saturday and had problems starting, took a good few attempts to get going, then when starting up a few hours later the revs were a bit erratic at idle going from 700rpm to around 2000rpm.

    Then tonight when driving home the emissions light came on although car drives fine and has started up / idled was normal.

    I first thought it was the ICV but z18xe's don't have one IIRC? I've only recently replaced the first lambda sensor a couple of months back so unless that's faulty...

    Any suggestions?

  2. #2
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

  3. #3
    Status
    Offline
    Scott D's Avatar
    AOC Fanatic
    Join Date
    Mar 2007
    Posts
    385
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    struggle to keep a mental note of all the flashes

    if its a P19-- are those last digits 10/11/12/13etc because im sure it fashed 12 times, thought it went upto 9 then onto next digit?

Similar Threads

  1. emissions light??
    By cliffty in forum Astra Discussion & Chat
    Replies: 3
    Last Post: 11-11-2012, 21:03
  2. Emissions light on 1.6 8v.
    By KrisC in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 3
    Last Post: 23-09-2006, 00:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •