Results 1 to 3 of 3

Thread: problems

  
  1. #1
    Status
    Offline
    gunner 25's Avatar
    AOC Newbie
    Join Date
    May 2009
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    problems

    i have my engine managment light on,had it put on the computer and it came up with the camshaft position sensor,which i havnt changed yet.it also came up with circuit malfunction how do i fix that.ever since i got the car it has juged and its like it runs on 3 cilinders and lack of power,would these problems cause this,it also came up with the map sensor,is it worth changing these things

  2. #2
    Status
    Offline
    Davee's Avatar
    AOC Obsessed
    Join Date
    Jan 2008
    Location
    Buckingham
    Posts
    1,664
    Mentioned in
    3 Post(s)
    Quoted
    0 Post(s)
    I'm not a professional mechanic but I will say that is exactly what is giving you problems.....

    Change the Camshaft position sensor first.....

  3. #3
    Status
    Offline
    gunner 25's Avatar
    AOC Newbie
    Join Date
    May 2009
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    im just waiting on 1 comming home il try that first thanx

Similar Threads

  1. 1.4 sxi idling problems and over fuelling problems
    By danny mcg in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 2
    Last Post: 15-03-2014, 17:38
  2. Problems with car / Problems with Regal Autosport
    By BigG33 in forum Turbo Petrol Engines inc. Transmissions
    Replies: 65
    Last Post: 10-07-2011, 13:00
  3. Replies: 59
    Last Post: 11-04-2007, 22:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •