Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Help needed error code P0302

  
  1. #1
    Status
    Offline
    Paul-H's Avatar
    AOC Newbie
    Join Date
    May 2009
    Posts
    21
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Help needed error code P0302

    Hi guys

    Just found the forum and looking for a bit of help

    My Son has just bought his first car a 2001 1.8 Astra Coupe

    He picked it up today and drove it home, about 100 miles, as he got near home the EML light came on

    The only thing that played up was the idle, it was very eratic going from 500 to 1000 RPM, apart from that the car still ran sweet.

    When he got home I connected my Code reader and it showed 1 code P0302 (Missfire Cylinder 2)

    Anyone got any tips on how to fix this, like I said the car runs fine apart from idle.

    The only other thing I noticed when the code reader was attached and I was watching the live data was the ignition advance kept changing.

    When the idle was fine it was reading 6 to 8 degree's advance and when the idle was eratic it was showing 2 to 20 degree's advance, don't know if it was just the ECU trying to correct the eratic idle by varying the advance or the varying advance producing the eratic idle.

    I have changed the plugs but that made no difference


    Thanks for any help and hope its not too expensive to fix as the car cost £3K and his insurance cost £1.8k and he has only had it one day.

    Thanks

    Paul

  2. #2
    Status
    Offline
    astracolli's Avatar
    AOC Obsessed
    Join Date
    Mar 2008
    Posts
    5,300
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    HT leads maybe?


    Vectra SRi 1.9 CDTi (150).
    Tinted Windows, Richbrook Gear Knob & Tax Disc Holder.
    Flip down sunglasses Holder.
    6000K HID's, Chilled Glovebox, CD70 Navi, Debadged, Samco Hoses.


  3. #3
    Status
    Offline
    Paul-H's Avatar
    AOC Newbie
    Join Date
    May 2009
    Posts
    21
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    It has no leads as such, it has a long coil pack that runs the width of the engine with four spark plug sockets built into it. The whole unit just plugs into the plugs.

    I suppose it could be the coil pack, but would it effect only one cylinder.

  4. #4
    Status
    Offline
    astracolli's Avatar
    AOC Obsessed
    Join Date
    Mar 2008
    Posts
    5,300
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    could be the coil pack then maybe?


    Vectra SRi 1.9 CDTi (150).
    Tinted Windows, Richbrook Gear Knob & Tax Disc Holder.
    Flip down sunglasses Holder.
    6000K HID's, Chilled Glovebox, CD70 Navi, Debadged, Samco Hoses.


  5. #5
    Status
    Offline
    Paul-H's Avatar
    AOC Newbie
    Join Date
    May 2009
    Posts
    21
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Up-Date

    I have ordered a coil pack, it should be with me tomorrow.

    I went for a drive to day and although the tickover was just as eratic the EML was no longer lit, I checked the stored codes with my reader and it said none stored or pending.

    Now the Imobilizer light is on (Car with Spanner though it)

    How do I diagnose that

    The car is running fine apart from the eratic tickover, which interestingly almost goes when the aircon is swithced on.

    Thanks

    Paul

  6. #6
    Status
    Offline
    jam's Avatar
    AOC Gold Member
    Join Date
    Apr 2005
    Location
    Tamworth, Staffordshire
    Posts
    11,695
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Follow jam On Twitter
    P0302 Cylinder 2 misfire

    Causes:
    Engine mechanical fault
    wiring
    ignition/fuel system
    Injector
    ECT/MAF sensor
    ECM

    My bet is your AFM is screwed. Its telling the ECU so much air is coming in = ECU adjusts the fuel mixture to compensate = floods cylinder 2 and causes misfire, H02S 1 picks up that its running too much fuel and tells ECU to compensate causing the lumpy idle as the ECU fights to keep the engine from stalling whilst trying to obey the H02S 1.

    I wouldn't bother with the coil pack for the moment instead I'd order an AFM.

    As for your immobiliser I suggest you let Vauxhall look at it. Worst case is the ECU has gone.

    jam
    Its a jam thing

    Haec credam a deo pio, a deo justo, a deo scito?



  7. #7
    Status
    Offline
    Paul-H's Avatar
    AOC Newbie
    Join Date
    May 2009
    Posts
    21
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks for the reply

    Whats the AFM

    Re immobilizer, I got a bit confused

    The car with spanner through it has 2 functions when engin is of its immobilizer when engin is running its engine management

    So with it coming on when engine is running is showing and engine fault but the ECU is not storing a code for the detected fault.

  8. #8
    Status
    Offline
    Paul-H's Avatar
    AOC Newbie
    Join Date
    May 2009
    Posts
    21
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hi Guys

    Just to confirm my confusion

    In the OP the light that came on mas not the EML light but the Exhaust Emission light Orange Engine with Code 0302 missfire cylinder 2

    Now Emission light is out and Light with Orange car with spanner is on but no code stored.

  9. #9
    Status
    Offline
    PeteG's Avatar
    AOC Premium Member
    Join Date
    Oct 2006
    Drives
    2.2 Astra G 3dr Hatch
    Location
    East Anglia
    Posts
    10,619
    Mentioned in
    4 Post(s)
    Quoted
    6 Post(s)
    Follow PeteG On Twitter
    "orange engine" is your engine emissions warning light mate. suggests to me that Jam's suggestion is along the right lines.

    car with spanner is engine/transmission electronics & immobiliser warning light. probably coming on now due to a sensor fault as a result of your previous problem.

    AFM's aren't too dear, try one and see if it works
    NOW - Sapphire Black 3dr Astra G

    THEN - Glacier White 2.0Di Estate - 136bhp 1.6 Pineapple Yellow Mk3 - Flame Red 2.0Di Van - Chianti Red 1.8 Coupe - Star Silver 2.2 Zafira - Flame Red 2.2 Linea Rossa Coupe - Titan Gold 1.8 Coupe

    9 Years, 7 Astras, 1 Zafira, No Regrets.

  10. #10
    Status
    Offline
    Paul-H's Avatar
    AOC Newbie
    Join Date
    May 2009
    Posts
    21
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    After reading on here I just went out and tried the pedal method of reading the codes as my code reader was showing no codes stored.

    Codes shown were 0302 as before and 1555

    I reset the codes and went for a drive untill the spanner light came back on and then checked the codes again and this time only 1555 was stored.

    HEEEELP please

Page 1 of 2 12 LastLast

Similar Threads

  1. Help needed Error code 1106 Zafira/Astra GSI
    By miln01782 in forum Zafira Discussion & Chat
    Replies: 0
    Last Post: 10-05-2013, 10:52
  2. Help needed:error code: p0130/P0136
    By n16871649 in forum Turbo Petrol Engines inc. Transmissions
    Replies: 6
    Last Post: 20-10-2011, 17:18
  3. Error code 0530 and random sensor found, Z20 LET Help Needed
    By alexp86 in forum Turbo Petrol Engines inc. Transmissions
    Replies: 3
    Last Post: 02-01-2011, 16:51

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •