Results 1 to 10 of 10

Thread: Changed wheel hub, now got funny sound

  
  1. #1
    Status
    Offline
    Tom{BSc}'s Avatar
    AOC Lite Member
    Join Date
    Feb 2008
    Posts
    611
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Question Changed wheel hub, now got funny sound

    After changing the passenger front wheel hub, due to a faulty abs sensor, the car made a real loud squeeking/howling sound from the brakes. So I whipped the wheel off and took half the caliper off, cleaned everything and put them back. The squeeking sound has now gone but there is still a light grinding sound I can hear. This sound can be heard when the car is plodding along normally and I drive past cars. It sounds pretty metallic. The hub was brand new but it's coming from the side that was changed :S. Could it be fitted badly or could this new hub be at fault?? It's a 5 stud 280mm front setup. Any help would be much appreciated. The pads and discs are both fine as they were changed to mintex pads and discs not so long ago. As I said, problem started after changing the hub. Do they need time to 'bed in'?? Any help is much appreciated. Thanks for reading!
    124.6 Bhp and 133.5 lb/ft from an x18xe1 (Now Sold)

    Now Drive a Corsa VXR

  2. #2
    Status
    Offline
    LTHastra16's Avatar
    AOC Newbie
    Join Date
    Feb 2009
    Posts
    15
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Im not too sure mate but it could be the bearing on the hub. Did you get a new bearing when you changed the hub? If not then that could be the answer otherwise im not sure.

  3. #3
    Status
    Offline
    Toms1989's Avatar
    Soft Top VTEC :)
    Join Date
    Dec 2007
    Posts
    11,356
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    Does it continue to squeek and rub when you dab the brakes at all?
    FULL Black Leather Heated coupe interior for sale! £200!!!
    Click Here

  4. #4
    Status
    Offline
    hep's Avatar
    AOC Fanatic
    Join Date
    Aug 2007
    Posts
    751
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    when you took the caliper off and cleaned everything, did you re-apply grease to the pads before putting them back in ?

  5. #5
    Status
    Offline
    Tom{BSc}'s Avatar
    AOC Lite Member
    Join Date
    Feb 2008
    Posts
    611
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I got the hub bit.. isn't that the bearing? When I brake the sound would go. But moving slowly makes it really loud. It's more of a grinding sound? Thanks for the help so far though. I copper greased everything
    124.6 Bhp and 133.5 lb/ft from an x18xe1 (Now Sold)

    Now Drive a Corsa VXR

  6. #6
    Status
    Offline
    D4nnyGsi's Avatar
    AOC Obsessed
    Join Date
    Jun 2007
    Posts
    1,031
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Check the disc guard behind the discs. it could be this catching the disc as it turns.

  7. #7
    Status
    Offline
    Tom{BSc}'s Avatar
    AOC Lite Member
    Join Date
    Feb 2008
    Posts
    611
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Yeah will have a look at that. Still got the funny sound. Suspension now creeks when I go over humps aswell lol. What a f**k up :/
    124.6 Bhp and 133.5 lb/ft from an x18xe1 (Now Sold)

    Now Drive a Corsa VXR

  8. #8
    Status
    Offline
    D4nnyGsi's Avatar
    AOC Obsessed
    Join Date
    Jun 2007
    Posts
    1,031
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Suspension creak is your anti roll bar bushes, either grease them or replace them but use rubber grease otherwise they'll be dry which causes that

  9. #9
    Status
    Offline
    Tom{BSc}'s Avatar
    AOC Lite Member
    Join Date
    Feb 2008
    Posts
    611
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    They were fine before we changed the hub, so could it be those bushes that are around the hub, theres a couple there I think... Will I have to take everything apart again to grease them up with the rubber grease stuff? The track rod end was slightly manhandled when changing this. Could this cause the creaking sound??
    124.6 Bhp and 133.5 lb/ft from an x18xe1 (Now Sold)

    Now Drive a Corsa VXR

  10. #10
    Status
    Offline
    D4nnyGsi's Avatar
    AOC Obsessed
    Join Date
    Jun 2007
    Posts
    1,031
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    You've gotta remove the bushes which sit on top of the subframe. Doubt the track rod end would cause that really.

Similar Threads

  1. Horn sound changed!
    By PiNiOn in forum Electrical
    Replies: 3
    Last Post: 16-06-2007, 00:33
  2. funny sound
    By flipcjl in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 2
    Last Post: 21-08-2005, 22:11
  3. Funny sound
    By flipcjl in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 2
    Last Post: 21-08-2005, 21:51

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •