Results 1 to 3 of 3

Thread: Having a few problems

  
  1. #1
    Status
    Offline
    maxx89's Avatar
    AOC Fanatic
    Join Date
    Jun 2007
    Posts
    757
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Having a few problems

    well im having a few problems with my dodo juice lime prime lite, when i put it on, it just wont buff off, then the blue velvet sits on top of it, so it just looks all smeary, seems to be mostly on the bonnet and rear panels of the van, ive stopped using it at the moment and just used srp, but also noticed it can do the same and wont buff off clearly, what am i doing wrong? is it somthing on the paint work that reacts badly with it? i had it machined polished by my mate and then used that on top. anyone got some ideas?
    Nürburgring BTG 9:52
    Roll on october trip

  2. #2
    Status
    Offline
    Burger Boy's Avatar
    AOC Obsessed
    Join Date
    Nov 2006
    Posts
    4,879
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    best to ask gaz as he has used it before.
    Castle Combe Saloon Car Championship. Car 21, pug 106 GTI. Gone from track days to full on racing

  3. #3
    Status
    Offline
    gazTD's Avatar
    AOC Gold Member
    Join Date
    Oct 2005
    Posts
    14,381
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    How long are you leaving it on the paint for before trying to buff off Maxx? Paint cleaners need to be applied to small areas at a time and buffed off almost instantly. Anything above 10 seconds and you will be struggling to get it off.

    One thing I find that helps a lot is using shagpile towels: http://www.cleanyourcar.co.uk/microf.../prod_436.html
    Gaz

    No longer owns an Astra


    Bye bye VXR Castle Combe Edition - because it's done more laps of Castle Combe than most Bergs have of the Ring

Similar Threads

  1. 1.4 sxi idling problems and over fuelling problems
    By danny mcg in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 2
    Last Post: 15-03-2014, 17:38
  2. Problems with car / Problems with Regal Autosport
    By BigG33 in forum Turbo Petrol Engines inc. Transmissions
    Replies: 65
    Last Post: 10-07-2011, 13:00
  3. Replies: 59
    Last Post: 11-04-2007, 22:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •