Results 1 to 6 of 6

Thread: 2.0 cdti/ecotec limp mode please all give oppinion on this

  
  1. #1
    Status
    Offline
    maglite's Avatar
    AOC Newbie
    Join Date
    Apr 2009
    Posts
    12
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Unhappy 2.0 cdti/ecotec limp mode please all give oppinion on this

    hello again all following previouse post and someone saying more info my astra is a 1999 2.0 cdti s reg / on my documents it sayd cd di ( not crackin on to insurance company ) , anyway car has been seen by 3 garages now and cheapest quote is 45 just to lift bonnet , just spoke to neibour who i didnt know had a garage and he has said he has repaired loads of these engines and it is definatly 2.0 cdti , the car is in what i been told is limp mode with no engine management light on , few weeks ago i noticed oil in road where car parked and had engine jet washed to find the leak as entire engine bay sprayed in oil , loads of people have gave advice on this and had loads of different versions of what it could be , my neibour has just said it is 1 of 2 things 1, oil on crank sensor ? 2, egr valve has water in and needs soaking in petrol or thiners then re try it . the oil leak is crank shaft oil seal( i have ready to do job ) im terrified of timingg as haynes shows specialist timing tools . and also is this crank sensor accesible to clean .

    sorry to rattle on but trawled through the forums and found many people with same problem but no definative answer , because engine managent light aint on everyone i have spoke to including neibour says tech 2 wont connect if light aint on to diagnose the fault any help much appriciated as i need car to see my kids on sundays 120 miles away , thanks again all. alan

  2. #2
    Status
    Offline
    maglite's Avatar
    AOC Newbie
    Join Date
    Apr 2009
    Posts
    12
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    sorry a bit more info , aparently the crank position sensor advances diesel pump timing , also as read in someone elses post that got no reply can i do further damage by driving car in limp mode it wil do 70 eventualy , its realy bad time for me not to see my kids x thinks im extractin eurine over car and i really dont have money to put it in garage going through bad split lol

  3. #3
    Status
    Offline
    ZS's Avatar
    AOC Obsessed
    Join Date
    Apr 2004
    Posts
    9,491
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Unless you have an engine out of an Insignia, you don't have a 2.0CDTi.

    You've probably got an Astra CD, with a 2.0Di engine.

    Could you rephrase the question/problem, preferably in to something we can understand, and we should be fit to help.
    2007 Metro Blue 5 door Mk5 Elite 1.7CDTI
    6th Vauxhall (4th Astra) in 10 years...plus a couple of other sheds...

  4. #4
    Status
    Offline
    astracolli's Avatar
    AOC Obsessed
    Join Date
    Mar 2008
    Posts
    5,300
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    If the warning lights have been on and then go of the fault code is stored in memory and will be able to be read at a altter date unless it has been wiped (ecu reset)!

    probs the egr valve


    Vectra SRi 1.9 CDTi (150).
    Tinted Windows, Richbrook Gear Knob & Tax Disc Holder.
    Flip down sunglasses Holder.
    6000K HID's, Chilled Glovebox, CD70 Navi, Debadged, Samco Hoses.


  5. #5
    Status
    Offline
    maglite's Avatar
    AOC Newbie
    Join Date
    Apr 2009
    Posts
    12
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    is so so happy did not get car but on tec2 i read the haynes manual and decided to look at all the vachume pipes as they didnt appear to match diagram in haynes manual , the pipes where in right places but routed wtong and on putting thenm in right place i found a pipe that had fused to the turbo at some point, cut out the melted section and hey presto problem solved thanks all ,,,,, im very happy now lol

  6. #6
    Status
    Offline
    ZS's Avatar
    AOC Obsessed
    Join Date
    Apr 2004
    Posts
    9,491
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Glad you got sorted.
    2007 Metro Blue 5 door Mk5 Elite 1.7CDTI
    6th Vauxhall (4th Astra) in 10 years...plus a couple of other sheds...

Similar Threads

  1. 1.9 cdti maf problem , limp mode
    By jaydexstar in forum Diesel Engines inc. Transmissions
    Replies: 2
    Last Post: 22-07-2014, 14:23
  2. Mk 5 1.9 CDTI Limp Mode???
    By Dickie_D in forum Astra Discussion & Chat
    Replies: 2
    Last Post: 31-01-2013, 21:20
  3. Limp Mode - Astra H 1.9 CDTI
    By badman in forum Diesel Engines inc. Transmissions
    Replies: 3
    Last Post: 17-05-2008, 01:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •