Results 1 to 8 of 8

Thread: just got car back from dealers....

  
  1. #1
    Status
    Offline
    idi's Avatar
    AOC Fanatic
    Join Date
    Apr 2009
    Posts
    567
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    just got car back from dealers....

    got a diagnostic done because engine management light was on and got the following error codes...
    P0100 (08 ) MASS OR VOLUME AIR FLOW MALFUNCTION
    U2103(04) CIRCUIT MANLFUNCTION
    U2103(04) CIRCUIT MANLFUNCTION
    P0980 (08 ) GLOW PLUG DEVICE ERROR. SUSPECT POSSIBLE WIRING FAULT

    i garage told me it will need a new air flow meter and since a new one will cost me 250quid + VAT, i just wanted to make sure. i got the car serviced a month ago so dont see how anything could go round with the glow plugs. starts perfectly fine but sometimes it decides not to let me go over 2000 revs and it also jerks ALOT.
    any help would be appreciated
    thank you

  2. #2
    Status
    Offline
    idi's Avatar
    AOC Fanatic
    Join Date
    Apr 2009
    Posts
    567
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    sumbody must know!

  3. #3
    Status
    Offline
    Astra-Zaf786's Avatar
    AOC Newbie
    Join Date
    Apr 2008
    Posts
    47
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    what car is it mate?

  4. #4
    Status
    Offline
    idi's Avatar
    AOC Fanatic
    Join Date
    Apr 2009
    Posts
    567
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    zafira 1.9cdti 150

  5. #5
    Status
    Offline
    terex's Avatar
    AOC Newbie
    Join Date
    Jan 2009
    Posts
    48
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    250 quid for an air flow meter....ouch !
    Try autovaux.co.uk or ebay for a new air flow meter.
    As for P0980 glow plug device error, it may just mean you have a faulty glow plug, if the engine starts without problems I wouldnt worry.

  6. #6
    Status
    Offline
    Ryan-AstraG's Avatar
    AOC Fanatic
    Join Date
    Oct 2008
    Posts
    709
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    have a look here mate, im too familar with what engine code it is.

    http://www.lmfvauxhall.co.uk/store/home.php?cat=2522

    if you get jumpyness, quite often than not the AFM can be the cause of it, and its a job you can do yourself,youd save quite abit of money
    Hey Dick,whats in for the Big Brain Quiz tonight? Certainly Gents, thats 200 quid. WHAT! each! DOUBLE WHAT! Thats abit steep isnt it...? steep...its f-ing verticle!

  7. #7
    Status
    Offline
    RobW's Avatar
    AOC Obsessed
    Join Date
    Jan 2005
    Posts
    3,411
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Could it have the injector 3 problem on the 150 cdti's?

  8. #8
    Status
    Offline
    idi's Avatar
    AOC Fanatic
    Join Date
    Apr 2009
    Posts
    567
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i cleaned out the MAF today and disconnected the battery for an hour. now there is no Engine light just the jumpyness and its SOOO anoying
    any idea whats causing it?

Similar Threads

  1. back in dealers again
    By reall1 in forum Zafira Discussion & Chat
    Replies: 2
    Last Post: 06-09-2009, 00:48
  2. VX Dealers
    By cornholio in forum Astra Discussion & Chat
    Replies: 24
    Last Post: 30-07-2007, 23:01

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •