Results 1 to 3 of 3

Thread: Astra 1.7 CDTI SXi (2004 G model)

  
  1. #1
    Status
    Offline
    mattlfc79's Avatar
    AOC Newbie
    Join Date
    Apr 2009
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Question Astra 1.7 CDTI SXi (2004 G model)

    Hi all I have the 1.7 CDTI SXi Astra (G model I think, not the most recent one anyway!) It has the Z17DTL 80hp engine

    Basically I am having some starting difficulties. The battery does not appear to hold its charge. Sometimes its fine for a couple of days and other times it looses charge over night!

    I have checked the battery voltage at 12.6V when the car is off. This rises to 14.09V when the car is running.

    I dont want to take it for a diagnostic incase there is something I can do to help diagnosis first!

    Is this a common problem with this car?

    Any help would be most greatly appreciated!!!

    Thanks

    Matt

  2. #2
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,745
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    Hi Matt

    Both those battery voltages are fine for charging and standing. You may find you have a dead battery or a faulty earth. I take it a jump start gets it going alright?
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  3. #3
    Status
    Offline
    mattlfc79's Avatar
    AOC Newbie
    Join Date
    Apr 2009
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hiya,

    Just what I thought, and yes a jump does get it going. New battery it is then!

    Thanks

Similar Threads

  1. Astra 1.7 cdti se (2013) model year
    By barryrobinson in forum Astra Discussion & Chat
    Replies: 0
    Last Post: 04-10-2012, 21:02
  2. Astra MK5 1.9 CDTi 120ps model
    By CDTi freak in forum Diesel Engines inc. Transmissions
    Replies: 0
    Last Post: 26-03-2010, 13:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •