Results 1 to 6 of 6

Thread: Wiper Help

  
  1. #1
    Status
    Offline
    Littleman's Avatar
    AOC Newbie
    Join Date
    Dec 2006
    Posts
    10
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Wiper Help

    Hi

    I have a 2002 MK4 Astra SXi and I have an issue with the intermittent wipers. In the fact that they dont a full sweap, only about 65% then they stop for some time and then do another 65% of the screen. Also when stopping the wiper they stop where ever they are at the time I switch them off.

    I have changed the wiper stalk but that made not change at all. I beleve they have a relay by the fuses, as I can hear chicking from there with the turning on and off of the intermittent wipers.

    Please can someone tell me which relay it is that controls the intermittent wipers as the manual was no help what so ever!!

    Thanks in advance

    Jon

  2. #2
    Status
    Offline
    Turboshed's Avatar
    AOC Obsessed
    Join Date
    Aug 2008
    Posts
    2,333
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    It might not be the relay that is at fault, it is more than likely your wiper motor and associated linkages, along with the park switch inside the motor, by all means try the relay, but I cant see it being that, I am not sure which relay it is on a mk4, sorry. However £15 - £20 for a new wiper motor from a breakers will sort that out for you, its probably a 20 minute job at the most, or at least it was when I did my Mk3 one
    Probably the ONLY Astra Mk3 sitting on Corsa D SXI rims!
    And Now a Diesel on Discs all round!

    http://www.astraownersclub.com/vb/sh...d.php?t=162503

  3. #3
    Status
    Offline
    Enigma ???'s Avatar
    AOC Obsessed
    Join Date
    Jul 2007
    Posts
    2,468
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    As ^^^^ has said it's the wiper motor, i think someone managed to fix the parking problem in the motor it's self don't know what they did

  4. #4
    Status
    Offline
    Turboshed's Avatar
    AOC Obsessed
    Join Date
    Aug 2008
    Posts
    2,333
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Enigma ??? View Post
    As ^^^^ has said it's the wiper motor, i think someone managed to fix the parking problem in the motor it's self don't know what they did
    I do recall reading something about that myself, from what i understand though, it involving taking apart the wiper motor itself, by drilling out some rivets and messing with the switchgear inside, it's probably a better option to simply replace it with a second hand one from a scrap car
    Probably the ONLY Astra Mk3 sitting on Corsa D SXI rims!
    And Now a Diesel on Discs all round!

    http://www.astraownersclub.com/vb/sh...d.php?t=162503

  5. #5
    Status
    Offline
    nry's Avatar
    Cumbria RO | Club Team
    Join Date
    Mar 2008
    Posts
    25,986
    Mentioned in
    48 Post(s)
    Quoted
    1 Post(s)
    2nd hand motor ~£35 with linkages on, plus 20 minutes to fit. Job done - this really is one of those easy fixes and easy jobs to do yourself.

  6. #6
    Status
    Offline
    Littleman's Avatar
    AOC Newbie
    Join Date
    Dec 2006
    Posts
    10
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    cheers for your advice guys, looks like I'm off to the scrap yard soon then!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •