Results 1 to 6 of 6

Thread: Boost pressure fault code help

  
  1. #1
    Status
    Offline
    LeeR's Avatar
    AOC Newbie
    Join Date
    Oct 2008
    Posts
    29
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Boost pressure fault code help

    Hi, my 1.7 CDTI 100 Astra has a problem with the spanner coming on and the car going into limp mode.

    I took the car over to forum member pecky. He ran a diagnostic and it came up with the following code:

    P0234 - Boost Pressure Control Circuit Positive Deviation.

    Does anyone have any advice please on what the code means and where to start as my mechanic is a bit stumped. Any help is gratefully appreciated.

    Back to pecky. While there he also fitted cruise control and I thoroughly recommend anyone needing help in his area to give him a shout. Top man.

  2. #2
    Status
    Offline
    pecky's Avatar
    AOC Premium Member
    Join Date
    Sep 2005
    Posts
    1,062
    Mentioned in
    8 Post(s)
    Quoted
    2 Post(s)
    A little research has turned up these two possibilities.

    Try taking the sensor off the back of the engine and cleaning it as it may be gunked up meaning the ECU can't measure the boost pressure because it doesn't know what the manifold pressure is.

    It may be the boost pressure vaccum solenoid, at the back of the engine at the bottom just above the drivers drive shaft, two ten mm bolts hold it on, two vaccum pipes coming off it


    Glad to be of assistance.

  3. #3
    Status
    Offline
    LeeR's Avatar
    AOC Newbie
    Join Date
    Oct 2008
    Posts
    29
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks for the information pecky. I've copied it down and will pass it on

  4. #4
    Status
    Offline
    bronze1200's Avatar
    AOC Newbie
    Join Date
    Dec 2010
    Posts
    6
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    thanks lads this exactly what i have so will have a gander at the soleniod now

  5. #5
    Status
    Offline
    bronze1200's Avatar
    AOC Newbie
    Join Date
    Dec 2010
    Posts
    6
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    bugger just realized for 1.7 never mind

  6. #6
    Status
    Offline
    solorider's Avatar
    AOC Obsessed
    Join Date
    Oct 2010
    Posts
    1,086
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    at worst it will be the turbo,the vanes stick causing the over boost situation,mine does it all the time,but check your vacuum pipes,there is a boost sensor on the manifold that can go wrong or you could have a leak in the intake system

Similar Threads

  1. P0105 Boost pressure fault code help
    By biswell in forum Diesel Engines inc. Transmissions
    Replies: 1
    Last Post: 05-03-2013, 17:46
  2. Low Boost Pressure - FAULT
    By turbobanana in forum Turbo Petrol Engines inc. Transmissions
    Replies: 6
    Last Post: 21-12-2007, 19:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •