Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Z18xe Low Mpg! Help!

  
  1. #1
    Status
    Offline
    steveyd83's Avatar
    AOC Newbie
    Join Date
    Mar 2009
    Posts
    9
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Exclamation Z18xe Low Mpg! Help!

    Hey guys. My 2001 1.8 16v astra (Z18XE) only does about 26 mpg. now i'm sure that its supposed to be more like 36 mpg? i have removed the throttle body and gave it a good clean but still no better. somebody mentioned the thermostat being faulty but i cannot see this myself? something about it affecting the cold start valve.
    I have plugged in op com and done some monitoring. the fuel/air ratio is rich most of the time but every so often changes to lean for about 1 second then back to rich. NOW HERES WHERE I'M CONFUSED! O2 sensor 01 fluctuates between 50 - 840mV whereas O2 sensor 2 stays constant at 784mV. so does this mean that sensor 1 is faulty and this is why the ratio is rich, or is this how it should be? just for the record there are no fault codes being show.

    I know this is a bit of a techi 1 sorry. all your feedback would be appreciated guys!

  2. #2
    Status
    Offline
    Kev.'s Avatar
    AOC Obsessed
    Join Date
    Jul 2007
    Posts
    9,820
    Mentioned in
    3 Post(s)
    Quoted
    7 Post(s)
    I know a lad who owned an Astra - the Z18XE with all the irmscher extras you could get. He bought it off a bloke who added everything you could near enough & when speaking to him, i remember him saying he got 26-28mpg out of it.

    Mine has no kit on it & personally, i hit 30-33mpg, which people see as being "low" but when i say i get 320-340 miles per tank, they say this is normal. Can't have it both ways surely, so which one is right?

    RE: codes - i've one of those £25 eBay readers & sometimes it shows up nothing, but the pedal test shows up codes. Have you tried the pedal test to see if any codes are stored?

    Heard that about the thermostat before. Does your temp gauige work as normal? Mine sat rock bottom & would ONLY move up when i was in stationary traffic. A new stat & sensor later & it sits at just about "90". Upped the mpg SLIIIIIIIGHTLY.

  3. #3
    Status
    Offline
    daaanboy's Avatar
    AOC Newbie
    Join Date
    Mar 2009
    Posts
    49
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    o2 sensor is always fluctuating because its reading the gases before it goes into the cat.

    the second 1 should fluctuate but not as much as the 1st sensor. there could be a fault within the 2nd o2 sensor.

    does it read constantly lean from the 2nd sensor?
    Astra MK4 1.6 5dr SXi {work in progress}

  4. #4
    Status
    Offline
    steveyd83's Avatar
    AOC Newbie
    Join Date
    Mar 2009
    Posts
    9
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    No daaanboy. the sensor never changes from 784mV and the ratio for sensor 2 is always rich! ahh i didn't look at it like that so maybe sensor 2 faulty then a?! are both of the sensors the same i.e could i poss swap em over?

    No kev 83 i haven't done the 'pedal test' how do you do the pedal test? and as for the thermostat kev 83 i have noticed the temp guage hovering around the low mark all of the time until stuck in traffic. don't think the stat is opening til nearly 100 c. do ya think i should change it? and wheres the sensor? WOW 320 miles per tank sounds good to me, i'm only gettin 260 - 280 miles at the mo lol

    CHEERS BOYS!

  5. #5
    Status
    Offline
    Sonic_Coupe's Avatar
    AOC Regular
    Join Date
    Jan 2009
    Posts
    244
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Sounds to me like your thermostat is stuck open if it never get's hot untill in traffic. If it is, then this would incress the time it takes the ecu to come off of cold running i.e more fuel being slung in.

    The after cat lambda sensor will stay nearly the same reading all the time. This is a good thing as it means your cat is working very well. The more the reading fluctuates at lambda sensor 2 the less efficant your cat is.
    Now Running Boost, AWD and a Flat 4.

  6. #6
    Status
    Offline
    daaanboy's Avatar
    AOC Newbie
    Join Date
    Mar 2009
    Posts
    49
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    what sonic coupe said does sound like a possible cause.
    but if i remember correctly (and correct me if im wrong) the stat is mechanical...not electrical so the ecu uses the coolant temp sensor in the coolant tank. so really the ecu should come off cold start mode.

    as with the sensors being the same...they are but its the length of the harness thats different. i think sensor 1 is longer so really you cant swap them.
    Astra MK4 1.6 5dr SXi {work in progress}

  7. #7
    Status
    Offline
    steveyd83's Avatar
    AOC Newbie
    Join Date
    Mar 2009
    Posts
    9
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    ok, so any ideas on wether O2 sensor 2 should be fluctuating or should both of the O2 sensors stay the same??????

  8. #8
    Status
    Offline
    Kev.'s Avatar
    AOC Obsessed
    Join Date
    Jul 2007
    Posts
    9,820
    Mentioned in
    3 Post(s)
    Quoted
    7 Post(s)
    couldn't give you any info RE: stat sensor mate. I just asked a garage to renew it as it seems to be a very common problem

    RE: pedal test

    * de-press brake & also accelerator .... keep them held until process it complete
    * key in ignition
    * turn once (i find it didn't work when i turned it straight to it)
    * turn once again (make them 2 seperate movements for the reason i stated above) so the lights come on
    * Count the flashes on the EML...

    10 flashes = 0. 1-9 flashes = 1-9 (so 1 flash = 1, 5 flashes = 5), 10 is the only one that equals another number.

    Write them down. AFAIK all codes are 4 numbers long. So you'll get for e.g.

    P0704
    then note the next code
    P0170

    and so on until it stops

    then come back & ask the guys in the know (not me) lol.

  9. #9
    Status
    Offline
    CiSportHatch's Avatar
    AOC Fanatic
    Join Date
    May 2008
    Posts
    513
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    Go Diesel Power.
    Silver 2008 Astra SXi 1.7CDTi 100

  10. #10
    Status
    Offline
    daaanboy's Avatar
    AOC Newbie
    Join Date
    Mar 2009
    Posts
    49
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    o2 sensor should fluctuate but at minimal amount.

    if its constant then either your cat is playing up or the 2nd sensor is faulty.
    Astra MK4 1.6 5dr SXi {work in progress}

Page 1 of 2 12 LastLast

Similar Threads

  1. differences between the saab z18xe and the vauxhall z18xe?
    By resu in forum Astra Discussion & Chat
    Replies: 2
    Last Post: 13-06-2010, 23:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •