Results 1 to 9 of 9

Thread: Early 2.0 DTi problems...

  
  1. #1
    Status
    Offline
    whitevanman88's Avatar
    AOC Newbie
    Join Date
    Mar 2009
    Posts
    48
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Early 2.0 DTi problems...

    Hi.

    I purchased a nice early 2001 Astra CD 2.0 DTi. I have now covered 22,000 trouble free miles since I got it in november. I do have a little of problems popping up.

    1. One of the backlights for the clock / radio display has failed. It is still fully readable at night, but in the daytime the side with the clock isn't easy (or possible) to read. Do they use the same backlights as in the MK3 astra? If so an easy repair.
    2. A couple of times this week, the car hasn't started easily, although still first time. After starting the service light and electronic cooling light (? been told thats what it is. Looks like a tank with snowflake in) stay on and the engine hunts badly at idle. Like "vroom ... vrooom ..." etc... almost stalling inbetween. Crank sensor?
    3. The mileage display used to display "check" (or something similar - can't quite remember) upon starting for a few seconds. It doesn't do this any more. Could it be related to the above problem?
    4. I appear to have a seized caliper on the back (discs all round). I have read this isn't uncommon. But the pad on it looks like new (the other side is due for replacement) so I'm guessing it has been seized for quite a while. The car was MOTd when I bought it for me and the only thing it failed on was a cracked coil spring. Surely it should have failed for a seized caliper?


    Sorry for all the points, and I know I'm not at all technical when it comes to cars, sorry.

    Thanks,

    Jon.

  2. #2
    Status
    Offline
    mfivebmw's Avatar
    AOC Fanatic
    Join Date
    Aug 2007
    Posts
    760
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hi ya,

    welcome to the club, i will make a start to try and help you and hopefully someone will be along to try and help you sort out some of the other things later,

    i got my backlight bulbs from Vauxhall for only a few pence/pounds, it was abit of a strip to fit, but it's not hard.

    Dave

  3. #3
    Status
    Offline
    whitevanman88's Avatar
    AOC Newbie
    Join Date
    Mar 2009
    Posts
    48
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by mfivebmw View Post
    Hi ya,

    welcome to the club, i will make a start to try and help you and hopefully someone will be along to try and help you sort out some of the other things later,

    i got my backlight bulbs from Vauxhall for only a few pence/pounds, it was abit of a strip to fit, but it's not hard.

    Dave
    Thanks for the reply. If the backlight bulbs are the same as the MK3 astra, I have loads floating about.... so I hope they are!

  4. #4
    Status
    Offline
    whitevanman88's Avatar
    AOC Newbie
    Join Date
    Mar 2009
    Posts
    48
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I would really appreciate some help with this - I have no other mechanically minded friends or whatever, so if I can't work out what's going on, it's a garage or nothing.

  5. #5
    Status
    Offline
    mfivebmw's Avatar
    AOC Fanatic
    Join Date
    Aug 2007
    Posts
    760
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Sorry Jon we weren't alot of help on this one,

    sometimes the faults can be very hard to find, without actually seeing the car.

    Are you in the AA or RAC? they might be able to help out,

    if not it looks like this time it's gunna end up in a Gge.

    don't give up on us (Club) we will always try and help out when we can.

    Dave

  6. #6
    Status
    Offline
    astracolli's Avatar
    AOC Obsessed
    Join Date
    Mar 2008
    Posts
    5,300
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Checked your coolant?
    Glow plugs?
    When was last service?


    Vectra SRi 1.9 CDTi (150).
    Tinted Windows, Richbrook Gear Knob & Tax Disc Holder.
    Flip down sunglasses Holder.
    6000K HID's, Chilled Glovebox, CD70 Navi, Debadged, Samco Hoses.


  7. #7
    Status
    Offline
    whitevanman88's Avatar
    AOC Newbie
    Join Date
    Mar 2009
    Posts
    48
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    mfivebmw : Don't worry! I have had a good look around here, and very impressed with the community. I won't be deserting you!

    Astracolli : Coolant is spot on, not dirty & the antifreeze saturation is spot on. Glow plugs have activated a couple of days, only when we had a frost. The starting problems seem to be more on warm starts too... Not a problem really with cold starting. No service book was provided with the car, but I will do all the fluids and an oil change (oil looks perfect too btw, on the dipstick and in the rocker cover) tomorrow.

    The car is still perfectly drivable (apart from the obvious brake problems, and I wouldn't be irresponsible enough to drive it on a public road like that...honest) and the starting problem hasn't actually re-occured since my first post on here.

    Thanks for all your help, guys.

  8. #8
    Status
    Offline
    astracolli's Avatar
    AOC Obsessed
    Join Date
    Mar 2008
    Posts
    5,300
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Shove some redex or sumink through it and see if that helps!

    Hope ya get it sorted!


    Vectra SRi 1.9 CDTi (150).
    Tinted Windows, Richbrook Gear Knob & Tax Disc Holder.
    Flip down sunglasses Holder.
    6000K HID's, Chilled Glovebox, CD70 Navi, Debadged, Samco Hoses.


  9. #9
    Status
    Offline
    whitevanman88's Avatar
    AOC Newbie
    Join Date
    Mar 2009
    Posts
    48
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks - I think i'll pop some wynns through it, always had good experiences with them. Will do a hot oil flush too. Although I've got a niggle that the starting problem is, infact, the crank sensor (from what I've read)

Similar Threads

  1. Early 1998 MK4 Astra 2.0 SRI Disc Problems...
    By TheDanishShark in forum Astra Discussion & Chat
    Replies: 1
    Last Post: 06-01-2008, 21:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •