Results 1 to 7 of 7

Thread: Need serious help!!

  
  1. #1
    Status
    Offline
    DemonikApe's Avatar
    AOC Regular
    Join Date
    Dec 2008
    Posts
    84
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Need serious help!!

    Ok, so i finished work tonight and on the way home went to over take a lorry. Just after I got past I felt a loss in power and a funny noise, its hard to explain... but now when ever i put my foot down theres two noises, sorry im not good at putting noises in words, one kinda queeky but not high pitch and the other a chainy noise... these come at about 1.5 to 2000 revs, its about when the turbo would kick in!!

    The car was boxed with the green kit, Ive taken that off and still is the same... It really does sound bad... Have I blown my turbo??

  2. #2
    Status
    Offline
    DemonikApe's Avatar
    AOC Regular
    Join Date
    Dec 2008
    Posts
    84
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Ok, so here's an update!

    I had a m8 over who used to work for toyota and he said that my turbo is fu**ed! He said I defo need a new turbo, so I've got a few questions!

    1) Is my turbo definataly covered under warrenty?
    2) Ive taken my green box off, but I've got a k&n pannel filter in, are vauxhall going to question me about this and say my cars not standard so they won't fix it?

  3. #3
    Status
    Offline
    B19 TOM's Avatar
    AOC Newbie
    Join Date
    Mar 2009
    Posts
    63
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    turbo is deffinatley covered under warranty and if i wa you for sake of a few quid id replace the filter, not saying they'l even notice the filter but better to be safe and all that. im sure if they can find any excuse to get out of a huge repair bill they will.

  4. #4
    Status
    Offline
    DemonikApe's Avatar
    AOC Regular
    Join Date
    Dec 2008
    Posts
    84
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Ok thanks. I'll have to get a standard one for now then!

    So why could this of hapend, is it down to the way I drive, or could the green box have somthing to do with it? I havnt had the car long but it's done 37k miles, it's possible that the previous owner thrashed it every where!

  5. #5
    Status
    Offline
    munkie's Avatar
    AstraSport Member
    Join Date
    Apr 2007
    Posts
    4,922
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    its all depends mate.

    Normally after driving high speeds your supposed to let the engine idle for a minute or so.

    As if you think about it your doing say 70-80mhp on a motorway, pull into a service station and turn the car off.

    The oil doesnt have enough time to cool the turbo down before it has stopped spinning and after a while that can cause problems. but thats all I know on the turbo.

  6. #6
    Status
    Offline
    knoxvillain's Avatar
    AOC Fanatic
    Join Date
    May 2008
    Posts
    680
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I believe a K&N filter doesn't affect the warranty. So they claim at least.
    No longer an astra owner

    Now a Vectra owner

  7. #7
    Status
    Offline
    DemonikApe's Avatar
    AOC Regular
    Join Date
    Dec 2008
    Posts
    84
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Yeah I was just looking on the K & N website and they clearly state that it doesnt void warrenty, so I think I'll tell them to take it up with K & N if I have any problems

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •