Results 1 to 9 of 9

Thread: GSi fault codes.

  
  1. #1
    Status
    Offline
    Iain-GSi's Avatar
    AOC Newbie
    Join Date
    Sep 2008
    Posts
    31
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Question GSi fault codes.

    Hi guys,

    My EML came on this morning on my GSi, did the pedal test and code 0170 came up. I did a search on here and from what I can see this means something to do with "Fuel system trim malfunction" Is this lambda sensor?

    Has anyone had this code?

    Cheers.

  2. #2
    Status
    Offline
    AndyM's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    2,675
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Another search came up with .....

    fuel supply, mixture adoptation when idling, limit for too lean/rich, adoptation in part load range.

    I'm not an expert, but could possibly be something like the lambda sensor, or manifold leak, or maybe MAF .....

  3. #3
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    pre-cat lambda....

    but sometimes AFM can cause it as it did with mine

    or even just cheap crap fuel as what happened to mine last week - just reset the code, give the lambda a clean in some petrol if u so wish and give the car a good run

  4. #4
    Status
    Offline
    Iain-GSi's Avatar
    AOC Newbie
    Join Date
    Sep 2008
    Posts
    31
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Cheers lads.

    My local VX has a pre-cat lambda in stock so i'm gonna pick that up and fit it 2nite and also gonna give the earth mod thing a try. I'll post the outcome!

  5. #5
    Status
    Offline
    andys sri-t's Avatar
    AOC Obsessed
    Join Date
    Aug 2008
    Posts
    1,514
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    mine did this along with a bad misfire and it was the front o2 sensor in the precat
    never drink and drive .you might spill your drink
    **** n/a turbo is the way

  6. #6
    Status
    Offline
    Iain-GSi's Avatar
    AOC Newbie
    Join Date
    Sep 2008
    Posts
    31
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Changed the sensor and sorted the dodgy earth (tbh i dont see what is wrong with the way VX had did the earth but I was in there so strenghtend it up) also cleaned the throttle body. Still have the EML on though.

    I have disconnected the battery for now to try and clear it. Fingers crossed!

  7. #7
    Status
    Offline
    glover's Avatar
    AOC Premium Member
    Join Date
    Feb 2008
    Posts
    181
    Mentioned in
    0 Post(s)
    Quoted
    2 Post(s)
    whats the issue with a dodgy earth ive heard about on z20lets? cheers
    Arden Blue MK4 GSi

  8. #8
    Status
    Offline
    Iain-GSi's Avatar
    AOC Newbie
    Join Date
    Sep 2008
    Posts
    31
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Ok so disconnecting the battery has turned the EML off but the code is still stored if I do the pedal test. is this ok or does it mean there is still a problem? The car runs fine.

    Glover,

    http://www.astraownersclub.com/vb/sh...ht=dodgy+earth

    I saw this when I was searching for the solution to my problem so thought I would try it. I wish I hadnt bothered but I had ripped the loom open so thought i'd best do something to it.

  9. #9
    Status
    Offline
    glover's Avatar
    AOC Premium Member
    Join Date
    Feb 2008
    Posts
    181
    Mentioned in
    0 Post(s)
    Quoted
    2 Post(s)
    that links very helpful, thanks!
    Arden Blue MK4 GSi

Similar Threads

  1. Temp gauge fault, 2 Fault codes
    By Autosparks in forum Turbo Petrol Engines inc. Transmissions
    Replies: 6
    Last Post: 29-11-2008, 17:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •