Results 1 to 9 of 9

Thread: Raceland Coilovers!!!

  
  1. #1
    Status
    Offline
    ollie86rn's Avatar
    AOC Newbie
    Join Date
    Feb 2009
    Posts
    12
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Exclamation Raceland Coilovers!!!

    Hey all, i know there has been a fair few threads on these coilovers so apologies if im repeating them. Brought and fitted a set a couple weeks back and since then ive had a couple of problems.

    1) The car seems to bottom out very easy, is this normal for the rest of you guys/gals with them fitted

    2) I also get a clonking noise (best way to describe it) which i think is the front coils turning in the mounts when i steer full lock at slow speeds. Again is this because i havnt tightend them hard enough in the mounts Beginning to get really annoying

    Any insight would be great, as i dont want to get rid of them but also dont want to damage the car at the same time! Cheers

  2. #2
    Status
    Offline
    turbomart's Avatar
    AOC Regular
    Join Date
    Jan 2009
    Posts
    214
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Dont know about number 2 but as for number one how much have to lowered it by? and on what size wheels?

  3. #3
    Status
    Offline
    Ellis_turbocoupe's Avatar
    AOC Regular
    Join Date
    Dec 2008
    Posts
    178
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I could be wrong mate is ive not changed a set but isnt there a bearing of some kind in the top mount thats supposed to be put in to stop that clonking?

  4. #4
    Status
    Offline
    astra1600's Avatar
    AOC Regular
    Join Date
    Dec 2008
    Posts
    175
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    mine was making a clonking noise. all i did is tightened it up and its not fine

  5. #5
    Status
    Offline
    dave_coupe's Avatar
    AOC Obsessed
    Join Date
    Nov 2005
    Posts
    3,497
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    Quote Originally Posted by Ellis_turbocoupe View Post
    I could be wrong mate is ive not changed a set but isnt there a bearing of some kind in the top mount thats supposed to be put in to stop that clonking?
    There is mate, the rubber bit and the bearings need to be taken of the top of the standard suspension! The knowing noise may also be the ARB catching!
    THE STATEMENTS MADE ABOVE ARE MERELY MY OPINION AND SHOULD NOT BE INTERPRETED AS STATEMENTS OF FACT UNLESS OTHERWISE STATED

  6. #6
    Status
    Offline
    Dan22's Avatar
    AOC Fanatic
    Join Date
    Nov 2007
    Posts
    656
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    had the same prob for a while, then when i found out about the bearing sorted it straight away. have you got a set to match the weight of your vehicles engine?

  7. #7
    Status
    Offline
    ollie86rn's Avatar
    AOC Newbie
    Join Date
    Feb 2009
    Posts
    12
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I take it that the bearings you are on about are the standard rubber bushes that sit on top of the old suspension uprights?

  8. #8
    Status
    Offline
    SRiTaff's Avatar
    AOC Obsessed
    Join Date
    Aug 2008
    Drives
    Zafira GSi
    Location
    Warrington,Cheshire
    Posts
    2,829
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Its all in here m8....
    http://www.astraownersclub.com/vb/sh...highlight=ebay

    Ye its a long thread but its got everything u need to know including pics,diagrams,answers to both your questions etc......
    . ..SRiTaff ...
    LIKE: ZletCruisers on Facebook.
    Drives: Arden Blue Zafira GSi.

  9. #9
    Status
    Offline
    Dan22's Avatar
    AOC Fanatic
    Join Date
    Nov 2007
    Posts
    656
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by ollie86rn View Post
    I take it that the bearings you are on about are the standard rubber bushes that sit on top of the old suspension uprights?
    no, there inside a plastic+metal cup which sat over the original springs. pull it apart and push the top bit out using a socket and hammer or similar and thats the bearing. it'l have grease inside it which i cleaned out and replaced with fresh grease

Similar Threads

  1. Who,s got Raceland Coilovers?
    By Jay_R in forum South East Region
    Replies: 2
    Last Post: 29-04-2009, 18:16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •