Page 1 of 5 12345 LastLast
Results 1 to 10 of 42

Thread: ZLET Conversion issues...

  
  1. #1
    Status
    Offline
    mdpburn's Avatar
    AOC Obsessed
    Join Date
    Feb 2009
    Posts
    1,602
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Red face ZLET Conversion issues...

    so got my car back from regal today! no lights on the dashboard or anything! to start with..... started driving and it keeps stalling when bringing it down a gear and at the lights etc also stall 50% of the time if you just rev whilst still it just cuts out! also i have no power before 3500rpm yes this is probally the boost settings but before it reaches 3500rpm it starts shaking when put to floor and it sounds like your at 6500rpm lol when your at 2000rpm! also engine lights just come on and another light - a car with a spanner through it? omg i hate my car right now! oh and it cost me £2300 to get engine fitted alltogether! any help?

    edit:to anyone reading the thread for first time please make sure you read near the end to avoid any misunderstanding! thanks
    ONLY DRIVE AS FAST AS YOUR ANGELS CAN FLY

  2. #2
    Status
    Offline
    SRI-T Keithy's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    5,745
    Mentioned in
    1 Post(s)
    Quoted
    0 Post(s)
    Take it back they should never have givin it to you like that

    White is the new Black

    FARMYARD TUNING

    LEH IS THE FUTURE

  3. #3
    Status
    Offline
    buckle's Avatar
    /
    Join Date
    Sep 2004
    Posts
    18,921
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    As above, take it back. Sure they will sort it for you.

  4. #4
    Status
    Offline
    trez's Avatar
    AOC Fanatic
    Join Date
    Mar 2008
    Posts
    924
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    dude...relax, i know its hard to...trust, i feel like u at mo...
    but take it back to them tomorrow and leave it with them to sort it out. say you dont want it back till its sorted. £2300 is a lot of money these days, so make em sort it mate. dont go doing anything to it yourself, just take it straight back in the morning
    Sapphire Black VxR Black Theme with a Touch of White, 3" Scorpion System, DapR springs, Rarb, JBI Tophat, FMIC & CDTI Conversion, Iridium Plugs, Full SMD in White...

  5. #5
    Status
    Offline
    mdpburn's Avatar
    AOC Obsessed
    Join Date
    Feb 2009
    Posts
    1,602
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    thing is it was fine for like 5miles lol then all hell broke lose! i rang them but it was closed! i am definetly going back tomorrow! problem is when i picked it up and he (chris) took me for drive it seemed fine! they probally guna charge me again! which i just cant afford! had to get a loan out so they could finish the work this time
    ONLY DRIVE AS FAST AS YOUR ANGELS CAN FLY

  6. #6
    Status
    Offline
    tim1547's Avatar
    AOC Obsessed
    Join Date
    Jan 2008
    Posts
    1,919
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    They will sort it for you dont worry about it. Didnt you notice as soon as u drove away?
    Astra coupe turbo 280bhp-sold
    BMW E60 5 Series M Sport

  7. #7
    Status
    Offline
    mattjk's Avatar
    AOC Fanatic
    Join Date
    Nov 2008
    Posts
    593
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    They wont charge you


    Also did you get the engine dropped into replace an different engine or were they just replacing it like for like?

    I had similar with one of my cars turned out to be something simple a loose earth

  8. #8
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    my guess is the AFM judging by the random stalling

    good luck anyway - keep us posted

    for peace of mind at least do the pedal test in the mean time to see what the spanner light refers to

    details here if u aint got a clue: http://www.astraownersclub.com/vb/sh...78&postcount=2

  9. #9
    Status
    Offline
    mdpburn's Avatar
    AOC Obsessed
    Join Date
    Feb 2009
    Posts
    1,602
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    it was an engine conversion! 2.0 turbo (z20let) for 2.0 non turbo (x20xev)
    no i didnt notice till like 5 miles in! i stalled and i thought wow im rusty lol then it kept doing it and i thought right ill pull over and ring them! and they were closed then the car wouldnt start i had to wait like 10 mins before it started! arrrghhh problem is i supplied engine so they will probally say its that! its really jerky but fine and f***ing fast above 3500rpm
    ONLY DRIVE AS FAST AS YOUR ANGELS CAN FLY

  10. #10
    Status
    Offline
    mattjk's Avatar
    AOC Fanatic
    Join Date
    Nov 2008
    Posts
    593
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    probably something simple matey

Page 1 of 5 12345 LastLast

Similar Threads

  1. ZLET boost issues
    By fastravan man in forum Turbo Petrol Engines inc. Transmissions
    Replies: 6
    Last Post: 11-08-2011, 21:08
  2. Serious Starting Issues Zlet
    By gleeballs in forum Turbo Petrol Engines inc. Transmissions
    Replies: 2
    Last Post: 11-10-2010, 20:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •