Page 1 of 4 1234 LastLast
Results 1 to 10 of 34

Thread: need some expert advice please guys

  
  1. #1
    Status
    Offline
    A5TRA 59ORT's Avatar
    AOC Gold Member
    Join Date
    Mar 2004
    Posts
    4,202
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)

    need some expert advice please guys

    Got a little problem with the Astra

    Only seems to happen when cold but Clare has been complaining of a jolting after changing gear and I first thought that the clutch was sticking as it's still the original clutch on 96K miles it made sense however itís not the clutch.

    I took the car for an extended journey today and after the first couple of miles I changed into 4th and the car just lost power. Felt like I was in too higher gear and the engine was laboring and then it jolted back to life and the engine electrics light blinked on.

    The car was then fine for the rest of the outward journey (100miles)

    On the way back today the car did the same thing again within 5mins of setting off. The first time was immediately after changing gear the second time was when changing lanes on the motorway.

    Since it started doing this the car has been serviced with a new set of plugs and the problem is still there.

    The car also had a new coil pack about 6 months ago.

    And Iím not sure if itís related but a few months back the car put the engine electric light up on the dash. I pulled over and turned the engine off and then on again and the light came back on after a few yards so then pulled over a bit further up the road turned the engine off opened the bonnet and did that very blokey thing of touching stuff under the bonnet as if I knew what I was doing anyhow after that the light never came back on.

    Anyone had anything similar??

    1.6 16v (x16xel)
    96k miles

    Cheers

    Chris

  2. #2
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Do the paperclip test Chris - see what comes up

    My guess is its the EGR valve clogged up

    even if its not then Id still clean that, together with the throttle body and ICV

    details on paperclip test here if ur unsure: http://www.astraownersclub.com/vb/sh...69&postcount=4
    (ignore the other references in this post as its lifted directly from another thread)

  3. #3
    fdrightup
    fdrightup's Avatar
    Quote Originally Posted by A5TRA 59ORT View Post
    Got a little problem with the Astra

    Only seems to happen when cold but Clare has been complaining of a jolting after changing gear and I first thought that the clutch was sticking as it's still the original clutch on 96K miles it made sense however itís not the clutch.

    I took the car for an extended journey today and after the first couple of miles I changed into 4th and the car just lost power. Felt like I was in too higher gear and the engine was laboring and then it jolted back to life and the engine electrics light blinked on.

    The car was then fine for the rest of the outward journey (100miles)

    On the way back today the car did the same thing again within 5mins of setting off. The first time was immediately after changing gear the second time was when changing lanes on the motorway.

    Since it started doing this the car has been serviced with a new set of plugs and the problem is still there.

    The car also had a new coil pack about 6 months ago.

    And Iím not sure if itís related but a few months back the car put the engine electric light up on the dash. I pulled over and turned the engine off and then on again and the light came back on after a few yards so then pulled over a bit further up the road turned the engine off opened the bonnet and did that very blokey thing of touching stuff under the bonnet as if I knew what I was doing anyhow after that the light never came back on.

    Anyone had anything similar??

    1.6 16v (x16xel)
    96k miles

    Cheers

    Chris
    could the jolting be lack of fuel to the engine

  4. #4
    Status
    Offline
    A5TRA 59ORT's Avatar
    AOC Gold Member
    Join Date
    Mar 2004
    Posts
    4,202
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    cheers for the replys guys,

    i will try the paper clip test when clare returns with the car later tonight and report back.

    it held the engine electrics light until clare turned the engine today so hopefully there will be some faults logged.

  5. #5
    Status
    Offline
    A5TRA 59ORT's Avatar
    AOC Gold Member
    Join Date
    Mar 2004
    Posts
    4,202
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    right guys,

    got the codes - not actaully that easy as i keep losing count

    anyhow the codes

    first code to appear was 1111110111111111101111 (this never repeated again)

    then in a repeating sequence

    10111101111111111011111
    101111110111111111101111

    Going by the link posted that should =

    604 = ????doesn't seem to be reckonised - (Ignore This Releasied i must of missed the start of this and it should be 1604 )
    1405 = EGR Valve
    1604 = Knock Control Unit

    so does that mean the EGR valve is dead?? the EGR valve was replaced around 3.5Years ago or is it just needing a good clean?

    also how do you get access to the ICV? i have in the past taken the inlet track off and cleaned out the top of the throttle body with carb cleaner but never any more than that. does the throttle body need to be remove in order to gain access to the ICV??

  6. #6
    Status
    Offline
    A5TRA 59ORT's Avatar
    AOC Gold Member
    Join Date
    Mar 2004
    Posts
    4,202
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    hi guys,

    took the EGR valve off the car and cleaned it out yesterday and also cleaned out the Throttle body.

    neither the EGR valve or throttle body where that dirty to be honest so i'm gussing that the EGR valve is on its way out.

    But what about the other error code - 1604 (Knock control Unit)
    is this related to the EGR valve or is it another falut that needs addressing?

  7. #7
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Chris - save some money and buy an EGR blanking plate instead

    Keep the EGR connected to the elec plug but either mount it away from the block cable tied out the way or mount it ontop of the blanking plate with a few washers sitting between the valve and blanking plate to provide enough clearance for the plunger to operate correctly...

    blanking plate costs anything from £4-10 depending on seller

    heres an example: £3.50 delivered: http://cgi.ebay.co.uk/EGR-VALVE-BLANK-PLATE-VAUXHALL-VECTRA-3-50-FREE-P-P_W0QQitemZ190289959769QQcmdZViewItemQQptZUK_CarsP arts_Vehicles_CarParts_SM?hash=item190289959769&_t rksid=p3286.c0.m14&_trkparms=72%3A1683|66%3A2|65%3 A12|39%3A1|240%3A1318


    not sure about the knock sensor in all honesty - it can be replaced but my EPC aint working at present so cant get any part numbers/prices etc

    Id defo advise the blanking plate tho - just cos the EGR is such a git as we all know how crap they can be at times.
    £50 will get u a new one but best off blanking it off and leaving it!

    If u need any help mate I'll be back down Sheff this weekend if u need a hand

  8. #8

  9. #9
    Status
    Offline
    A5TRA 59ORT's Avatar
    AOC Gold Member
    Join Date
    Mar 2004
    Posts
    4,202
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    Marti thanks for the reply,

    Would the EGR valve still not throw the warning light up if its blanked off or not as its still faluty?
    i don't mind buying a new one as i would hate to get to the point that i was ignoring warning lights thinking its the egr valve when there was something else causing the problem.

    Showing my lack of knowledge now but:
    the error code is related to the Knock Control Unit - so would replacing a sensor fix the error code? and also is there one knock sensor per cynlinder?

    and finally is it possible that the error code has come up because the car sensed the engine knocking and not that there is a fault with the unit?

    Cheers again for your help

  10. #10
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    ive been having doubts about the EGR blanking myself in this very scenario - due to the EML flashing up etc - if it was just giving poor running and no EML then maybe blanking it off would be for the best but in this situation maybe you are right in thinking a replacement would be best.

    The correct EGR for your X16XEL is part number 17098361 but comes in at a little more than i quoted earlier as I gave the price for the later 1.6 model

    Heres the best price I could find for your motor - £64.50 delivered

    http://cgi.ebay.co.uk/Vauxhall-EGR-Valve-Astra-Zafira-Vectra-1-4-1-6-17098361_W0QQitemZ230325220646QQcmdZViewItemQQptZU K_CarsParts_Vehicles_CarParts_SM?hash=item23032522 0646&_trksid=p3286.c0.m14&_trkparms=72%3A1683|66%3 A2|65%3A12|39%3A1|240%3A1318



    As for the knock sensor I really have absolutely zero knowledge on this im afraid - it could even be linked to the EGR fault so you may wish to address the EGR valve first, clear the codes (ie disc battery for half hour or unplug the 2 big plugs on the ECU for 10 mins if u dont have stereo code etc or dont want to lose power to H/U) then take it from there

Page 1 of 4 1234 LastLast

Similar Threads

  1. eml malfunction - need some expert advice
    By Kyle_mk4 in forum Electrical
    Replies: 2
    Last Post: 01-08-2009, 12:27
  2. Your expert advice on 'value'
    By Darren SXi 1.8 in forum Astra Discussion & Chat
    Replies: 2
    Last Post: 11-05-2007, 11:01

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •