Results 1 to 10 of 10

Thread: lambda sensor fitting

  
  1. #1
    Status
    Offline
    Scott D's Avatar
    AOC Fanatic
    Join Date
    Mar 2007
    Posts
    385
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    lambda sensor fitting

    I'm going to replace the front lambda sensor tomorrow which should be a straight forward job but double checking as not 100% confident.

    Is it a simple case of unplugging, unscrewing and then the reverse or might there be a few snags?

  2. #2
    Status
    Offline
    mikesmith2's Avatar
    AOC Regular
    Join Date
    May 2007
    Posts
    219
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    It really is a case of unplugging unscrewing and then the reverse.

    You will need a swan necked spanner though as you are unable to get an ordinary one on there.

    With the right spanner it's a five minute job.

  3. #3
    Status
    Offline
    SRiTaff's Avatar
    AOC Obsessed
    Join Date
    Aug 2008
    Drives
    Zafira GSi
    Location
    Warrington,Cheshire
    Posts
    2,829
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Just stick an adjustable spanner on it budJust screw it of,then straight back on .
    . ..SRiTaff ...
    LIKE: ZletCruisers on Facebook.
    Drives: Arden Blue Zafira GSi.

  4. #4
    fdrightup
    fdrightup's Avatar
    some times if the o2 sensor gets stuck ie can not be un done then heat will
    be needed

  5. #5
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    depending on the size of the elec plug used - u may be able to slip a ring spanner over the end and on - otherwise an open ender should be more than enough

    may be good to do it when engine is warm - just watch u dont burn ur self!

  6. #6
    Status
    Offline
    Scott D's Avatar
    AOC Fanatic
    Join Date
    Mar 2007
    Posts
    385
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    cheers for the advice

    fingers crossed i'll be able to get rid of the emission warning light tomorrow

  7. #7
    Status
    Offline
    DJAv's Avatar
    AOC Premium Member
    Join Date
    Jun 2007
    Drives
    Astra H Design 2.0T
    Location
    Cambridgeshire
    Posts
    1,414
    Mentioned in
    8 Post(s)
    Quoted
    31 Post(s)
    How did you get on?

    J
    Astra MK4 SXI 1.6 Twinport [Z16XEP] (2004) & Astra MK5 Design 2.0T [Z20LEL] (2006) & Zafira MK1 [Z18XE] (2003)|| Astra MK4 1.6 SXI [Z16XE] (2002) || Astra MK5 VXR [Z20LEH] (2007) || Astra MK4 1.6 SXI [Z16XE] (2001) || Vectra MK2 1.6 LS (1999) || Astra MK2 1.4 Merit (1990)

    Click here for the How To's

  8. #8
    Status
    Offline
    Scott D's Avatar
    AOC Fanatic
    Join Date
    Mar 2007
    Posts
    385
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    did it today

    took a bit of brute force using a lamdba socket but it came off eventually and all is well.

    dead easy to do after getting the old sensor out.

  9. #9
    Status
    Offline
    DJAv's Avatar
    AOC Premium Member
    Join Date
    Jun 2007
    Drives
    Astra H Design 2.0T
    Location
    Cambridgeshire
    Posts
    1,414
    Mentioned in
    8 Post(s)
    Quoted
    31 Post(s)
    Quote Originally Posted by Scott D View Post
    did it today

    took a bit of brute force using a lamdba socket but it came off eventually and all is well.

    dead easy to do after getting the old sensor out.
    Excellent!

    J
    Astra MK4 SXI 1.6 Twinport [Z16XEP] (2004) & Astra MK5 Design 2.0T [Z20LEL] (2006) & Zafira MK1 [Z18XE] (2003)|| Astra MK4 1.6 SXI [Z16XE] (2002) || Astra MK5 VXR [Z20LEH] (2007) || Astra MK4 1.6 SXI [Z16XE] (2001) || Vectra MK2 1.6 LS (1999) || Astra MK2 1.4 Merit (1990)

    Click here for the How To's

  10. #10
    Status
    Offline
    Topper's Avatar
    AOC Newbie
    Join Date
    Oct 2007
    Posts
    68
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Scott D View Post
    did it today

    took a bit of brute force using a lamdba socket but it came off eventually and all is well.

    dead easy to do after getting the old sensor out.
    Did it fix your problem ? what where your symptoms to change the Lambda Sensor ?

Similar Threads

  1. lambda sensor
    By JordanK in forum Bodywork and Exterior
    Replies: 10
    Last Post: 05-12-2010, 01:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •