Results 1 to 6 of 6

Thread: Air Mass sensor???

  
  1. #1
    Status
    Offline
    paul_bunce's Avatar
    AOC Obsessed
    Join Date
    Jul 2005
    Location
    Downham Market
    Posts
    1,936
    Mentioned in
    24 Post(s)
    Quoted
    17 Post(s)

    Air Mass sensor???

    Last week (Tuesday) I was driving along and my traction light came on along with the emission light and the car died on me. The AA ran live diagnostics and showed the air mass sensor showing no air going into the engine. The sensor was unplugged so I could drive to a local motor factors to pick up a new one. I fitted the new sensor and all was well until saturday when the emission light has come back on and now the car feels a little under powered. I have fault codes to show AMM malfunction and fuel trim malfunction but I think this was from the origional sensor failure.
    Any ideas? its a Z18XE
    Astra H SRi 1.9 CDTI
    WG Motorworks stage 1.5 Remap, VXR suspension, Whiteline RARB, Courtenay brake hoses, VXR brakes,
    OP COM East Anglia Region

  2. #2
    Status
    Offline
    paul_bunce's Avatar
    AOC Obsessed
    Join Date
    Jul 2005
    Location
    Downham Market
    Posts
    1,936
    Mentioned in
    24 Post(s)
    Quoted
    17 Post(s)
    Oh and one other thing, on start up the idle is fairly eratic claming down after a minuite or so.
    Astra H SRi 1.9 CDTI
    WG Motorworks stage 1.5 Remap, VXR suspension, Whiteline RARB, Courtenay brake hoses, VXR brakes,
    OP COM East Anglia Region

  3. #3
    Status
    Offline
    DrewWhelan's Avatar
    AOC Obsessed
    Join Date
    Jul 2007
    Posts
    2,445
    Mentioned in
    9 Post(s)
    Quoted
    6 Post(s)
    Have you had the fault cleared since you replaced the part?

    If you haven't got access to a diagnostic tool, try unplugging the battery for 30 mins which should reset the ecu.
    Connect the battery again and it should be ok.

    If the fault comes back it could be something more serious.

  4. #4
    Status
    Offline
    paul_bunce's Avatar
    AOC Obsessed
    Join Date
    Jul 2005
    Location
    Downham Market
    Posts
    1,936
    Mentioned in
    24 Post(s)
    Quoted
    17 Post(s)
    Disconnecting the battery doesnt clear any codes, I have tried it before with other codes overnight, I think ill have to get a diagnostic tool to clear them.
    Astra H SRi 1.9 CDTI
    WG Motorworks stage 1.5 Remap, VXR suspension, Whiteline RARB, Courtenay brake hoses, VXR brakes,
    OP COM East Anglia Region

  5. #5
    Status
    Offline
    DrewWhelan's Avatar
    AOC Obsessed
    Join Date
    Jul 2007
    Posts
    2,445
    Mentioned in
    9 Post(s)
    Quoted
    6 Post(s)
    If I was closer I'd do it for you,

    An elm327 device is fairly cheap on Ebay, and there is a wealth of free diagnostic software out there too:

    http://www.obdallinone.com/sc/pages.asp?pageid=60

    Very good even for just checking sensor outputs around the car

  6. #6
    Status
    Offline
    DrewWhelan's Avatar
    AOC Obsessed
    Join Date
    Jul 2007
    Posts
    2,445
    Mentioned in
    9 Post(s)
    Quoted
    6 Post(s)
    By the way, how much did you pay for your AFM?

    I was quoted £112 from Vauxhall today, £92 with trade discount,

    Value for money?
    picture this:
    I can buy a Nintendo DS lite for 95 quid with touch screen, wifi, microphone, video games, music etc.

    A plastic tube from vauxhall with a couple of diodes... rip off!

Similar Threads

  1. air mass sensor ????????
    By andybob in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 3
    Last Post: 14-04-2013, 21:19
  2. air mass sensor
    By Gilly in forum Turbo Petrol Engines inc. Transmissions
    Replies: 4
    Last Post: 02-11-2004, 19:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •