Results 1 to 9 of 9

Thread: Low Power - Astra 1.9CDTi Z19DTH

  
  1. #1
    Status
    Offline
    SwirlValveAl's Avatar
    AOC Newbie
    Join Date
    Feb 2009
    Posts
    3
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Low Power - Astra 1.9CDTi Z19DTH

    Hi, anyone recognise this problem and offer an opinion?...

    I have a 55 plate Astra 1.9CDTi Z19DTH, 45K, FDSH, no modifications, faulty EGR valve replaced at 24K. Car has developed an intermittent problem with low power - very obvious in 1st to 4th gear less obvious in 5th & 6th but still there. Going up through gears when I let clutch up there is a long pause before power kicks in or power never really comes on and I have to drop a gear to force revs up. No engine management light showing. Car more responsive in sport mode but problem still there. Removed and cleaned EGR valve - no improvement. Dealer checked car and advised swirl chamber valve was problem and replaced - no improvement but dealer claims diagnostics and test drives after replacing valve show no problem with car!! Not so, I've done 35K+ in the car and know exactly how it drives and it ain't right. Stalemate with dealer - any thoughts?

  2. #2
    Status
    Offline
    SwirlValveAl's Avatar
    AOC Newbie
    Join Date
    Feb 2009
    Posts
    3
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Angry The Sequel

    Car back in dealers 24hrs later for more diagnostic checks and extended test drive. Dealer still maintains no problem detected - agree to run car for a week and log any problems. 2 days in and engine management light comes on without warning, car drops into low power mode. Car back into dealers next morning - dealer phones to say fault was sticky EGR valve (that would be the same one replaced at 24K that I cleaned thoroughly before first visit to dealer would it?), cleaned and freed. Pick up car and first 5 miles are good no problems then as engine warms car starts "pulsing" and shuddering when accelerating. Alarming. Car back in dealers for a week for further checks. The party just goes on and on.............

  3. #3
    Status
    Offline
    dp88's Avatar
    Moderator
    Join Date
    Apr 2007
    Location
    Hartlepool, United Kingdom
    Posts
    5,988
    Mentioned in
    37 Post(s)
    Quoted
    18 Post(s)
    When my car lost power, the turbo basiclly didnt work.

    Turned out to be the swirl valves, inlet manifold, some cracked pipe and something else. Mine was covered by warranty tho

  4. #4
    Status
    Offline
    Turboshmick's Avatar
    AOC Newbie
    Join Date
    Feb 2009
    Posts
    5
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    No offence but does this only happen when its cold? as there is a safety rev limiter mapped into the ECU that will only allow 4000rpm until running temp reached

  5. #5
    Status
    Offline
    sport-hatch150's Avatar
    AOC Obsessed
    Join Date
    Jun 2007
    Posts
    1,907
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    you dont need 4000 rpm on the diesel to get moving, 4000 rpm in 6th is a shade under 140mph. Im wondering about the EGR valve and swirl valves. Is it smoking at low / high revs ? Have you given it a dose of redex ? any tuning box fitted ?

    You can test swirl valve yourself. With car off note position, turn on and leave ticking over, if its moved its conected. Make sure linkage hasnt come off !

    EGR valve dirty gave me very low power from cold and EM light. Clean out & redex flush back to its best.

    Hope it helps. Keep us posted.

  6. #6
    Status
    Offline
    SwirlValveAl's Avatar
    AOC Newbie
    Join Date
    Feb 2009
    Posts
    3
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Finally...

    Service Manager at dealership runs my car for two days and calls me to apologise and accepts that there is obviously a fault that has not been correctly diagnosed and fixed. His conclusion is faulty EGR valve at root of the problem. Free courtesy car and paid fuel for two weeks, new EGR valve fitted, no charge even though car is 6 months out of warranty. Fair play. Car running perfectly. If I picked him up correctly I'm sure he said "modified/improved" EGR valve fitted. Anybody heard same? - if anyone's interested let me know through this forum and I will post the details.

  7. #7
    Status
    Offline
    adsew123's Avatar
    AOC Newbie
    Join Date
    Jan 2010
    Posts
    1
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    hi i have been searching the net and the problem you had with your astra is very similar to the problem i currently have with my 1.9 cdti 06 astra. i have very little power upto around 2.5-3 thousand revs. when the revs are above that the car runs fine with a lot of power. i changed my air mass meter sensor (because local vauxhall garage said that was the problem) but the problem was still there. do you think the EGR valve needs replacing

  8. #8
    Razzzle
    Razzzle's Avatar
    Hi all,

    1st post here so bare with me.

    I'm having the problem listed above, no power until about 2.5k revs, swirl valve rod has come loose but i've seen a fix for a quid for that on a forums, cant remember where so am going to try that and see if it helps. im guessing the swirl flaps are stuck in the open direction as the power only seems to come in from higher revvs.

    Daz.

  9. #9
    Status
    Offline
    granger123's Avatar
    AOC Newbie
    Join Date
    Feb 2013
    Posts
    1
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    hi there i just bought the astra 1.9cdti 150 x pack 2007 have black smoke cumming out when waiting for turbo to kick in then its not to bad after that. been reading online took egr valve and boost sensor off today and now the engine light is on and turbo not kicking in till 2300rpm and more black smoke dont feel as powerfull when i got it can any one help me out someone said bout swirl bar what is that and any ideas y turbo is cumming in so late !!!!!! in need of advice

Similar Threads

  1. Astra H Z19DTH loss of power
    By Dharmjeet in forum Diesel Engines inc. Transmissions
    Replies: 12
    Last Post: 17-05-2014, 16:35
  2. P2279 fault code and No Power Astra Z19DTH
    By jason r in forum Diesel Engines inc. Transmissions
    Replies: 1
    Last Post: 19-03-2009, 21:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •