Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Zafira Z20LET Ticking Noise

  
  1. #1
    Status
    Offline
    damosmokie's Avatar
    AOC Fanatic
    Join Date
    Apr 2007
    Posts
    300
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Zafira Z20LET Ticking Noise

    I have a Zafira GSI Z20LET now I have got an leh turbo fitted. But I have recently had a water leak from one of the pipes that goes into the bottom of the turbo. I removed the turbo fitted new copper washers and replaced the turbo. But I have noticed since doing this job that I have developed a ticking noise. Also there is a sign of oil in my intercooler pipe which I noticed when I removed the turbo. Am I looking at a new set of lifters or could it be something else?

  2. #2
    Status
    Offline
    zaffi's Avatar
    AOC Regular
    Join Date
    Nov 2008
    Posts
    78
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    when does it do the ticking and roughly where from and oil in turbo boost pipe and intercooler is normal as long as aint loads

  3. #3
    Status
    Offline
    damosmokie's Avatar
    AOC Fanatic
    Join Date
    Apr 2007
    Posts
    300
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Ticking all the time sounds like its from the cam cover area but sound travels. Its not loads of oil but it was just something I noticed.

  4. #4
    Status
    Offline
    Windrew's Avatar
    AOC Obsessed
    Join Date
    Jan 2005
    Location
    Golborne, Wigan, United Kingdom
    Posts
    4,637
    Mentioned in
    2 Post(s)
    Quoted
    5 Post(s)
    its not the carbon canistor is it? the bit thats on the airbox has 2 pipes to it? thats normaly whats ticking!
    ARDEN BLUE GSI

  5. #5
    Status
    Offline
    rovkid's Avatar
    AOC Regular
    Join Date
    Jun 2008
    Posts
    290
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    U get oil in the intercooler hoses on alot of cars specially vauxhalls, the tickin noise could b a sticky tappet. The Z20LETs have hydraulic tappets........dont they, am sure they do. I get sticky tappet problems on my red top track corsa. I just put in a sludge cleaner run it 15mins then cahnge the oil and its ok for another 3 months lol.
    Red MK4 GSI on 19s

  6. #6
    Status
    Offline
    damosmokie's Avatar
    AOC Fanatic
    Join Date
    Apr 2007
    Posts
    300
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Windrew View Post
    its not the carbon canistor is it? the bit thats on the airbox has 2 pipes to it? thats normaly whats ticking!
    I will check this out tomorrow a the ticking is doing my head in. Thanks

  7. #7
    Status
    Offline
    damosmokie's Avatar
    AOC Fanatic
    Join Date
    Apr 2007
    Posts
    300
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by rovkid View Post
    U get oil in the intercooler hoses on alot of cars specially vauxhalls, the tickin noise could b a sticky tappet. The Z20LETs have hydraulic tappets........dont they, am sure they do. I get sticky tappet problems on my red top track corsa. I just put in a sludge cleaner run it 15mins then cahnge the oil and its ok for another 3 months lol.
    I used to have a red top astra and that used to tick until the lifters were changed. Will try a sludge cleaner just incase. Thanks

  8. #8
    Status
    Offline
    redeyes456's Avatar
    AOC Newbie
    Join Date
    Jan 2009
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Windrew View Post
    its not the carbon canistor is it? the bit thats on the airbox has 2 pipes to it? thats normaly whats ticking!
    I too have this ticking noise from this part i think tho not all the time, is this normal?

  9. #9
    Status
    Offline
    damosmokie's Avatar
    AOC Fanatic
    Join Date
    Apr 2007
    Posts
    300
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I have changed my oil and used a sludge cleaner still got the annoying ticking noise I am led to believe that it is my exhaust front pipe flexi has anyone known these to go and if so where did you buy replacements from?

  10. #10
    Status
    Offline
    52Minty's Avatar
    AOC Regular
    Join Date
    May 2008
    Posts
    107
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Mine ticks as well, has been doing it for a while now. Ive tried engine flush but didnt make any difference but i have been told that i may take a few flushes if the tappets are caped in crap. A vaux dealer also told me that my cam lobes are worn too which will cause it to tap.

Page 1 of 2 12 LastLast

Similar Threads

  1. Z20let Ticking/ Tapping noise
    By racey90 in forum Turbo Petrol Engines inc. Transmissions
    Replies: 18
    Last Post: 12-06-2012, 18:25
  2. Ticking noise please look
    By briggzy in forum Astra Discussion & Chat
    Replies: 5
    Last Post: 02-02-2012, 08:37
  3. Ticking noise from around the TB
    By Danny_ in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 9
    Last Post: 20-01-2008, 22:47

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •