Results 1 to 5 of 5

Thread: Stiff Steering and Alternator Light

  
  1. #1
    Status
    Offline
    robhull32's Avatar
    AOC Newbie
    Join Date
    Jan 2009
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Stiff Steering and Alternator Light

    Hi, I own a MK4 Astra 1.6. This morning I started the car up for the first time in a couple of months. Everything was ok, I drove for a couple of miles to buy petrol and then returned home. However just as I was about to drive into my garage the steering went suddenly stiff and the alternator light came on.

    What has gone wrong? Can anyone help me, thanks in advance.

  2. #2
    Status
    Offline
    KevT.'s Avatar
    Yorkshire RO
    Join Date
    Jul 2005
    Location
    Bradford
    Posts
    9,218
    Mentioned in
    7 Post(s)
    Quoted
    15 Post(s)
    check the Altonator belt to make sure it aint come off or snapped. Not sure if it runs the powersteering pump or not but i had a ford van that snapped the altonator belt and the powersteering also went.

    AOC top 15 car at PVS 2009 & 2010
    313.7bhp/343Ibft


  3. #3
    Status
    Offline
    robhull32's Avatar
    AOC Newbie
    Join Date
    Jan 2009
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Cheers, I`ll have a look. The Haynes manual said something about the drive belt but I wasn`t sure.

  4. #4
    Status
    Offline
    Windrew's Avatar
    AOC Obsessed
    Join Date
    Jan 2005
    Location
    Golborne, Wigan, United Kingdom
    Posts
    4,637
    Mentioned in
    2 Post(s)
    Quoted
    5 Post(s)
    have you got a multi meter? you need to check the voltage output of the alternator, does the car start ok? and how olds the battery?
    ARDEN BLUE GSI

  5. #5
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    after checking the obvious drive belt it sounds like ur alternator has given up the ghost or ur battery is dead

    more than likely the alt

    youll defo need a digi multi meter tho to check voltages - when off, when idle and at revs

    if it shows about 12 when off and 14.4v give or take a few decimals then its ok - if considerably less than 13.5v when running then the alt is dead

    battery light means its not charging

    pas system is a high user of power so this is shut off straight away to conserve valuable power

    HTH

Similar Threads

  1. Power steering gone stiff
    By ashsri-t in forum Electrical
    Replies: 3
    Last Post: 14-08-2012, 11:23
  2. Stiff Steering
    By WSF in forum Chassis
    Replies: 3
    Last Post: 30-05-2007, 14:35

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •