Results 1 to 2 of 2

Thread: Instrument panel fault?

  1. #1
    Duke's Avatar
    AOC Newbie
    Join Date
    Dec 2008
    Mentioned in
    0 Post(s)
    0 Post(s)

    Instrument panel fault?

    Hi to everyone. Ive just joined and seek the help of someone with my 1999 Astra Club 8v 1.6. which has an intermittent fault. At random the readings via the instrument panel will cease whilst driving along and it includes the oddometer reading (digital), fuel guage, coolant temperature guage and speedo. They all come back on when either indicator is applied (though not for long). There appears to be no other effects on the vehicle, but I would like to read my instuments whils driving, especially the speedo!!! Can anyone think of a possible cause and solution?

  2. #2
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    VXR Nurburgring
    N/W London
    Mentioned in
    114 Post(s)
    70 Post(s)
    Welcome mate

    The obvious place to start looking will be the main connector to the panel, i've heard these can be loose sometimes
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason

Similar Threads

  1. Instrument panel always lit up......
    By adamthepostie in forum Electrical
    Replies: 1
    Last Post: 13-03-2012, 23:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts