Results 1 to 7 of 7

Thread: rubbish heaters

  
  1. #1
    Status
    Offline
    stabes's Avatar
    AOC Regular
    Join Date
    Feb 2008
    Posts
    200
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    rubbish heaters

    having a little trouble with my heaters, they dont seem to be blowing very strong, the fan sound's normal but the air coming out of the vents seem's weaker than it should be, if i put it on face and feet for instance i have to put them on full to get the airflow i would expect on say setting number 2, any idea's?

  2. #2
    Status
    Offline
    Windrew's Avatar
    AOC Obsessed
    Join Date
    Jan 2005
    Location
    Golborne, Wigan, United Kingdom
    Posts
    4,637
    Mentioned in
    2 Post(s)
    Quoted
    5 Post(s)
    sounds like a pipes come off, does the fan speed up when you turn it up?
    ARDEN BLUE GSI

  3. #3
    Status
    Offline
    NewAstraOwner's Avatar
    AOC Newbie
    Join Date
    Dec 2008
    Posts
    11
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    I have the same issue

    Hi, I also have this issue! The fan does speed up when moving between 1, 2, 3, 4 settings (Well it gets louder anyway). But the heat coming out is terrible.

    I have noticed the temp gauge doesnt move for ages either, then jumps to halfway and the aircon does not work. (The light comes on when I press the button but there is no change in the air coming out).

    I need to replace my water pump, would you know if this has anything to do with it? (Sorry, I don't know much about cars.)

    Any Ideas? Thanks.

  4. #4
    Status
    Offline
    stabes's Avatar
    AOC Regular
    Join Date
    Feb 2008
    Posts
    200
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    yeah my fan speed's up jus really weak comin through the vents, jus come home n had em on n fan doesn't seem as fast as other car's ive had

  5. #5
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,745
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    Try changing, or at least removing your pollen filter for now. It may be so clogged up that air can't be sucked through it
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  6. #6
    Status
    Offline
    stabes's Avatar
    AOC Regular
    Join Date
    Feb 2008
    Posts
    200
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    silly question but howd i get to the pollen filter, could probably find it but its cold and dark outside so will try it tomorrow on my lunch break

  7. #7
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,745
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    It's behind the glovebox if you couldn't find it

    I'm sure there's a how-to on it
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





Similar Threads

  1. hid + fk = rubbish, help
    By unreal_event_horizon in forum Electrical
    Replies: 27
    Last Post: 30-08-2012, 22:17
  2. Heaters are rubbish HELP
    By sarah27 in forum Interior
    Replies: 9
    Last Post: 12-12-2006, 18:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •