Results 1 to 4 of 4

Thread: engine temperature sensor

  
  1. #1
    Status
    Offline
    eug4611's Avatar
    AOC Newbie
    Join Date
    Mar 2007
    Posts
    44
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)

    engine temperature sensor

    hi people,

    a mate of mine has a 1.6 meriva and the temp guage in the dash does not move even when it has been driving for 30-40 mins on our journey to work, also noticed the other day that the heater vents dont give out that much heat even when turned up full.
    so my question is does he need a thermostat or a engine temp sensor?
    does anyone have any ideas or have any of you experienced anything like this yourselves, any help would be greatly appreciated.
    many thanks in advance.

  2. #2
    Status
    Offline
    alan geh's Avatar
    AOC Fanatic
    Join Date
    Mar 2007
    Posts
    405
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    if the heater aint getting hot then the thermostat is shot

  3. #3
    Status
    Offline
    Planty's Avatar
    AOC Fanatic
    Join Date
    Jul 2005
    Posts
    406
    Mentioned in
    1 Post(s)
    Quoted
    0 Post(s)
    just got ours replaced today and the temp goes straight up (when car is warmed anyway),
    so yes, could be the temp sensor
    Please contact the HelpDesk if you wish to become a Trader. Thanks

  4. #4
    Status
    Offline
    firefly's Avatar
    AOC Newbie
    Join Date
    Jan 2008
    Posts
    72
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I had this problem recently, and it was the thermostat. Apparently they get stuck open very easily. Mine was getting stuck due to corrosion or dirt, and I probably could have cleaned it but I just replaced it.

    Some suppliers only sell a thermostat complete with a new housing, which you probably don't need - I was able to get the thermostat on it's own from my local motor shop, for about 1/4 of the price of the one with the housing, so shop around!

Similar Threads

  1. P0115 - Engine Coolant Temperature Sensor Circuit Range/Performance NO HEAT
    By MartinAstra2005 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 15
    Last Post: 12-12-2010, 13:32
  2. 1.6 engine temperature sensor
    By anth12 in forum Turbo Petrol Engines inc. Transmissions
    Replies: 2
    Last Post: 08-11-2009, 18:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •