Results 1 to 8 of 8

Thread: rough idle

  
  1. #1
    Status
    Offline
    -matt's Avatar
    AOC Regular
    Join Date
    Oct 2008
    Posts
    160
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    rough idle

    ive got an o2 sri turbo, which is all standard apart from a de-restricted airbox.

    recently at idle it keeps revving slightly then going back down, then back up and continually doing this. and it does this wheather its hot or cold.

    is there any reason why its doing this? or a way to get it nice and smooth?

    matt

  2. #2
    Status
    Offline
    alan hanson's Avatar
    AOC Fanatic
    Join Date
    Jun 2007
    Posts
    469
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i had this try cleaning the TB or idle control valve if it has one should do the trick

  3. #3
    Status
    Offline
    mib gsi turbo's Avatar
    AOC Fanatic
    Join Date
    Jan 2006
    Posts
    471
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    mite also be afm.
    use to drive arden blue gsi turbo.now sold
    239 bhp and 244 lb/ft
    bought astra cdti xp 150

  4. #4
    Status
    Offline
    mattcoupturbo's Avatar
    AOC Obsessed
    Join Date
    Aug 2005
    Posts
    4,765
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Could also be this, it sorted mine out.

    www.astraownersclub.com/vb/showthread.php?t=117185

  5. #5
    Status
    Offline
    mart_gsi_turbo's Avatar
    AOC Fanatic
    Join Date
    Sep 2008
    Posts
    912
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    do the pedal trick to get codes or even better if you have a fault code reader also worth will checking your vacum pipes that can make it rough idle
    Arden Blue GSI And You Know Its The Best Colour To Have

  6. #6
    Status
    Offline
    webbo gsi's Avatar
    AOC Obsessed
    Join Date
    May 2007
    Posts
    1,548
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by mattcoupturbo View Post
    Could also be this, it sorted mine out.

    www.astraownersclub.com/vb/showthread.php?t=117185
    most likly cause i would say! mine was idling real bad but i did this and its not missed a beat!

  7. #7
    Status
    Offline
    scruffyblackgsi's Avatar
    AOC Newbie
    Join Date
    May 2007
    Posts
    35
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I had the same problem, hooked it up to a bosch code reader and got a fault code for the crank sensor, had this changed but didnt make any difference. Can anybody say if the car feels jerky when driving especially when accelerating and scrubs speed off quickly when you take your foot off the pedal? could this all to be in connection with the earth fault?

    I found a post on VXnet(?) about some new codes at VX garages which bypass the EGR. Anybody had this done?

  8. #8
    Status
    Offline
    webbo gsi's Avatar
    AOC Obsessed
    Join Date
    May 2007
    Posts
    1,548
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    z20let has no egr!

Similar Threads

  1. slightly rough idle and flickering lights at idle
    By pdrpaul in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 19
    Last Post: 27-02-2015, 22:08
  2. Rough Idle
    By gsi_lee87 in forum Turbo Petrol Engines inc. Transmissions
    Replies: 3
    Last Post: 07-05-2010, 13:38

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •