Results 1 to 5 of 5

Thread: Z22SE sounding like a subaru & driving like a pig

  
  1. #1
    Status
    Offline
    blingblingbob's Avatar
    AOC Newbie
    Join Date
    May 2008
    Posts
    13
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Z22SE sounding like a subaru & driving like a pig

    SRI 2.2L

    I've done the de-restrictions to the airbox, opened up my intake pipe (we dont have diesel vectras in australia) and drilled out the pre cat (what a mongrel of a job that was). Must say thats been the best bang for buck I've ever done.

    But now after 6mths of trouble free thrashing (since the alternator regulator died) its giving me grief. It sounds like a Subaru and is running at about 1/2 - 2/3 power, cuts in and out from being good and not. I hope its not the coil pack again I already replaced that 2 years ago with a brand new genuine one. The engine light has only come on once for like 4 seconds. I suspect its running on 2 or 3 cylinders. Could it just be a dirty spark plug? they're quite new and genuine as well.

    Any help apreciated.

    Cheers

    Rob

  2. #2
    Status
    Offline
    badboysracing69's Avatar
    AOC Regular
    Join Date
    Nov 2006
    Posts
    228
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Sounds like coil pack. Not much else goes wrong? Might be faulty plug though?
    Cheap Vaux mech at your service in Herts/cambs

  3. #3
    Status
    Offline
    blingblingbob's Avatar
    AOC Newbie
    Join Date
    May 2008
    Posts
    13
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Is there like an aftermarket MSD one I can get instead of burning money on these pieces of junk?

    I'll replace the plugs and see how it goes.

  4. #4
    Status
    Offline
    blingblingbob's Avatar
    AOC Newbie
    Join Date
    May 2008
    Posts
    13
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Not spark plugs.

    Any MSD coils avalible?

  5. #5
    Status
    Offline
    blingblingbob's Avatar
    AOC Newbie
    Join Date
    May 2008
    Posts
    13
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Replaced the coil pack/ignition modual. Fixed.

Similar Threads

  1. Z22SE - erratic idle and smell of fuel after driving.
    By PeteG in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 3
    Last Post: 03-09-2010, 12:05

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •