Results 1 to 5 of 5

Thread: astra 2.0dti bad starting

  
  1. #1
    Status
    Offline
    smirnoff_rules's Avatar
    AOC Newbie
    Join Date
    Apr 2008
    Posts
    72
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    astra 2.0dti bad starting

    got a car coming in tomorrow , the aa say its the injector seals .. but had one like this a year back a sent it out to a injector specialist and he changed the pump ..


    wots more common on there .. thinking l might out this one too as the seals r a nightmare to change

    or is there anything else to look out for .. starts all days but if he leaves for over 8 hours it will not start ..

    might be glow plugs but l have heard they have air in fuel problems

  2. #2
    Status
    Offline
    dogsbolox's Avatar
    AOC Regular
    Join Date
    Oct 2007
    Posts
    240
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Yeah go for injector seals, cheapest option. Ive done one of these.Simple to do.
    Take rocker off and just loosen the bolts for cam slightly so the injectors will go in and out without damaging the seals.
    I bought a kit off vauxhall, you got rocker gasket,rubber injector pipes and the 4 injector seals.
    The problem was starting it when it had been stood a while.But once the engine was warm it was ok.
    I had to tow it to get it started, it was on a 2.0 dti vectra. Common fault on vectra's done 5 so far

  3. #3
    Status
    Offline
    smirnoff_rules's Avatar
    AOC Newbie
    Join Date
    Apr 2008
    Posts
    72
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by dogsbolox View Post
    Yeah go for injector seals, cheapest option. Ive done one of these.Simple to do.
    Take rocker off and just loosen the bolts for cam slightly so the injectors will go in and out without damaging the seals.
    I bought a kit off vauxhall, you got rocker gasket,rubber injector pipes and the 4 injector seals.
    The problem was starting it when it had been stood a while.But once the engine was warm it was ok.
    I had to tow it to get it started, it was on a 2.0 dti vectra. Common fault on vectra's done 5 so far
    so l'll get the lift on the chain end on number one injector ok then ? cheers

  4. #4
    Status
    Offline
    dogsbolox's Avatar
    AOC Regular
    Join Date
    Oct 2007
    Posts
    240
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    yeah, just loosen the bolt s for the cam with the chain still on, you will have enough clearence to put the seal on and the injectors back in, took me about 45 mins to 1 hr to do the whole job

  5. #5
    Status
    Offline
    smirnoff_rules's Avatar
    AOC Newbie
    Join Date
    Apr 2008
    Posts
    72
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by dogsbolox View Post
    yeah, just loosen the bolt s for the cam with the chain still on, you will have enough clearence to put the seal on and the injectors back in, took me about 45 mins to 1 hr to do the whole job
    cheers m8 , just sorted , easy one , thanks for your help ..

Similar Threads

  1. Astra 2.0DTi (Y20 DTH) starting problem.
    By mattware49 in forum Diesel Engines inc. Transmissions
    Replies: 0
    Last Post: 24-08-2014, 20:33
  2. 2.0DTi EGR valve - bad starting?
    By nry in forum Diesel Engines inc. Transmissions
    Replies: 11
    Last Post: 23-09-2011, 17:55
  3. Astra 2.0dti starting problems
    By kyle_dlk in forum Diesel Engines inc. Transmissions
    Replies: 7
    Last Post: 17-12-2007, 17:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •