Results 1 to 6 of 6

Thread: afm ?

  
  1. #1
    Status
    Offline
    mick's Avatar
    AOC Fanatic
    Join Date
    Jun 2007
    Posts
    409
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    afm ?

    had an emissions light on or a couple of months now and not had time to sort it, but noticed today that im not gettin any over boost. when driven its just boosting to 8 psi and staying bang on ! had suspected the afm for the emissions but could it cause a lack of over boost ? are these two problems likely to be linked to one fault ? had the codes read when the eml first came on and it was fuel trim ( bank 1 ) any ideas welcome, i dont want to be replaceing loads of parts to sort it out ( the missus already moans about the amount of money spent on the car ) !

  2. #2
    Status
    Offline
    tim1547's Avatar
    AOC Obsessed
    Join Date
    Jan 2008
    Posts
    1,919
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Sounds likely it could be the afm although unfortunately there is no way to tell %100 if its shagged. Symptoms are rough idle and holding back. I've had a couple go on me so far and it felt the same each time i.e doesn't pick up well from low revs, boost not kicking in as should, holding back etc.

    Check your plugs and for leaks/split in your vacuum hoses as well mate just in case its not AFM. If it is AFM then make sure you buy a genuine bosch part from a reliable garage/retailer not a refurbished one!
    Astra coupe turbo 280bhp-sold
    BMW E60 5 Series M Sport

  3. #3
    Status
    Offline
    montyfox's Avatar
    AOC Obsessed
    Join Date
    Apr 2006
    Posts
    7,434
    Mentioned in
    1 Post(s)
    Quoted
    1 Post(s)
    Quote Originally Posted by mick View Post
    ..... any ideas welcome, i dont want to be replaceing loads of parts to sort it out ( the missus already moans about the amount of money spent on the car ) !
    If thats the case, an internet forum probably isn't the best place to be asking for definative answers! All members can give you is their honest, educated guesses based on their own experiences.

    So for my guess, I'm with Tim, a duff AFM will still sort of work but won't be metering the air properly.
    Try disconecting the AFM to see if the car runs a little better without it.

    Sorry if I'm wrong but it is only a guess

  4. #4
    Status
    Offline
    Madmonkee's Avatar
    AOC Fanatic
    Join Date
    Sep 2004
    Posts
    654
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    is the car standard? My emissions light kept coming on after having full sports exhaust. It needed remapping really to clear it.
    Aerospace NDT LvlII Technician En4179/Nas410.
    Certified, qualified Crack tester :P

  5. #5
    Status
    Offline
    TurboManiak's Avatar
    AOC Regular
    Join Date
    Oct 2008
    Posts
    262
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Pull the plug on the AFM and restart your ECU ... start the engine ... if it stalls and cant idle properly its probably the O2 sensor ... if it works better than right now that should mean AFM.

    Thats my guess
    The only way to be 100% certain that work has been done properly is to do it yourself.

  6. #6
    Status
    Offline
    mick's Avatar
    AOC Fanatic
    Join Date
    Jun 2007
    Posts
    409
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    cool will try that tomorrow, at the end of the day this will only be sorted with parts and that is where other peoples experiences come in to play, thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •