Results 1 to 4 of 4

Thread: Oil pressure light randomly comming on!!

  
  1. #1
    Status
    Offline
    Skell18's Avatar
    AOC Obsessed
    Join Date
    Nov 2007
    Posts
    1,159
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Oil pressure light randomly comming on!!

    Right today I was sitting in traffic when my oil light started flashing, not like an indicator light flash but flickering, but it only did this when I was stopped in traffic once i started moving it went off. I checked the dip stick and its all fine, I put some oil in anyway and on the way home tonight no light untill I had got off the motorway and was sat at some traffic lights when oil light started flickering, now I had been driving at about 85mph on the motorway, once off the motorway I was going at a steady 40-50mph on the A55 and then when i stopped at lights etc no oil light, I am completely baffled!! Any takers?

    I should add the car was only serviced last week, oil changed etc etc and when I floor it there is an annoying buzzing sound comming from the area around the airbox I think but its deffo on the driverside from the engine bay, i have had a look and nothing is loose etc, all this happened after it was serviced!
    Quote Originally Posted by Ffoeg View Post
    It has happened in the past , but I do try to be discrete but a 'poo with a view' is one of life's simple pleasures IMO
    Quote Originally Posted by Craig View Post
    i have owned two fannys that have blown smoke

  2. #2
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    id change the oil pressure switch matey - cheap as chips and a doddle to do

    what engine/year is it again?

    heres the part I bought for my old engine which resolved the same issue
    http://cgi.ebay.co.uk/Vauxhall-CAVALIER-ASTRA-CORSA-OIL-PRESSURE-SWITCH-NEW_W0QQitemZ370084905432QQcmdZViewItem?hash=item3 70084905432&_trkparms=72%3A1301|39%3A1|66%3A2|65%3 A12|240%3A1318&_trksid=p3286.c0.m14

  3. #3
    Status
    Offline
    Skell18's Avatar
    AOC Obsessed
    Join Date
    Nov 2007
    Posts
    1,159
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    its a Z14XE early 2003 model
    Quote Originally Posted by Ffoeg View Post
    It has happened in the past , but I do try to be discrete but a 'poo with a view' is one of life's simple pleasures IMO
    Quote Originally Posted by Craig View Post
    i have owned two fannys that have blown smoke

  4. #4
    Status
    Offline
    Stevie1556's Avatar
    AOC Fanatic
    Join Date
    May 2006
    Posts
    780
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I had this on my Z18XE engine last year.

    Basicly, the oil pressure switch has failed. When you press teh accellerator pedal the switch isn't in use as oil gets pushed around the engine properly, but when the car is idleling the oil pressure switch keeps the pressure up and keeps the oil flowing properly. When you're just sitting there and the light come on, it's basicly throwing oil out all over the road.

    I got a new one from vxl for about a fiver. I had a garage change it for me, but if it was now then I would do it myself. All you need to do is unplug is, unscrew it, screw the new one in and put teh plug back on

    I dunno where it is on your engine, but on mine is was on the back about 5cm up, behind the drivers pedals.


    Hope that helps

Similar Threads

  1. traction control light comming on after fitting dump valve??? Help please
    By micky taylor 888 in forum Turbo Petrol Engines inc. Transmissions
    Replies: 2
    Last Post: 17-09-2008, 20:43

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •