Results 1 to 6 of 6

Thread: speedo stopped working

  
  1. #1
    Status
    Offline
    Softtop Ritchie's Avatar
    AOC Regular
    Join Date
    Oct 2007
    Posts
    128
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    speedo stopped working

    I have tried finding an answer via other threads and cant find what I'm looking for

    I have a 53plate 1.8 cab and the speedo dial just isnt working the rest are apart from the temp sensor as I've misplaced the needle for it but on checking with the fuel gauge it makes no difference ,

    Irecently changed the dash to blue just yesterday and now this has happened does anyone have any ideas

    if took the cluster off and refited it still to no avail

    if i need to get a new part for the back can i do this or is it all new clocks

    ritchie
    AMG'd Europa Blue 1.8 Cabby, Badgeless Grill & opelised, Custom Built Oval Exhaust, 8K HIDs, Full Alpine Setup + ipod.

  2. #2
    Status
    Offline
    Softtop Ritchie's Avatar
    AOC Regular
    Join Date
    Oct 2007
    Posts
    128
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    oki so can i buy a set of clock say from a scrapyard and take the wee piece were the miilage shows from my clocks and i should be oki or do i need to buy clocks and have the mailage changed

    ritchie
    AMG'd Europa Blue 1.8 Cabby, Badgeless Grill & opelised, Custom Built Oval Exhaust, 8K HIDs, Full Alpine Setup + ipod.

  3. #3
    Status
    Offline
    Oddjob's Avatar
    AOC Obsessed
    Join Date
    May 2003
    Posts
    5,213
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    The mileage is stored in the EPROM on the circuit board, just changing the mileage screen won't make any difference. Did the fuel warning light come on by any chance when you changed the bulbs to LEDs?
    52 Astra G 1.8, 18" Mille Miglia alloys, 325mm Brembo 4 pot conversion, Coupe leather interior, Raid strut brace, Whiteline rear ARB, Irmscher bits (skirts, Carbon steering wheel, Bonnet extension, M3 mirrors, boot & roof spoiler), Reiger Rear Diffuser & Front Bumper, Koni Adj. dampers, 35/30 Vogtland springs, Duplex quad exit ASCAR stainless exhaust.

  4. #4
    Status
    Offline
    Softtop Ritchie's Avatar
    AOC Regular
    Join Date
    Oct 2007
    Posts
    128
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    no fuel light came on buddy , the dials still dont work and changed the bulbs back to normal , but nothings working and fogs aint working

    ritchie
    AMG'd Europa Blue 1.8 Cabby, Badgeless Grill & opelised, Custom Built Oval Exhaust, 8K HIDs, Full Alpine Setup + ipod.

  5. #5
    Status
    Offline
    Oddjob's Avatar
    AOC Obsessed
    Join Date
    May 2003
    Posts
    5,213
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Does the handbrake warning light come on? and more importantly does it go off when you take the handbrake off?

    I've seen something similar and it was caused by a faulty LED, this fried the board before you could really spot it unless you knew exactly what to spot. The fuel warning is one sign, the handbrake is another. The speedo just refuses to work, certain parts of it do but not the most important parts.
    I had to change the speedo in the end.
    52 Astra G 1.8, 18" Mille Miglia alloys, 325mm Brembo 4 pot conversion, Coupe leather interior, Raid strut brace, Whiteline rear ARB, Irmscher bits (skirts, Carbon steering wheel, Bonnet extension, M3 mirrors, boot & roof spoiler), Reiger Rear Diffuser & Front Bumper, Koni Adj. dampers, 35/30 Vogtland springs, Duplex quad exit ASCAR stainless exhaust.

  6. #6
    Status
    Offline
    Softtop Ritchie's Avatar
    AOC Regular
    Join Date
    Oct 2007
    Posts
    128
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I've ordered A new dash cluster buddy got it through warranty should get it in a day or two

    no warning signs or that just a gubbed speedo so heres hoping the new one works oki :P

    cheers for answering this post tho

    ritchie
    AMG'd Europa Blue 1.8 Cabby, Badgeless Grill & opelised, Custom Built Oval Exhaust, 8K HIDs, Full Alpine Setup + ipod.

Similar Threads

  1. Speedo just stopped working!!!
    By neileos in forum Astra Discussion & Chat
    Replies: 6
    Last Post: 21-10-2008, 15:01
  2. Speedo has stopped working...
    By Keefo in forum Electrical
    Replies: 3
    Last Post: 24-05-2008, 19:44
  3. help, speedo stopped working
    By heds in forum Bodywork and Exterior
    Replies: 5
    Last Post: 09-07-2004, 17:45

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •