Results 1 to 4 of 4

Thread: Power steering pump being a right pain!

  
  1. #1
    Status
    Offline
    ant46's Avatar
    AOC Newbie
    Join Date
    Sep 2006
    Posts
    35
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Power steering pump being a right pain!

    Hi everyone was just wondering if anyone has ever had this problem before?

    I have an AstraG 1.6 8V, the power steering pump is of the 2 point electical type and has decided to stop working. Well I say stop working, when I start the car the first time the pump doesnt run. Then I turn the engine off, restart and turn the wheel ever so slightly to the left and all of a sudden it starts working. Once its up and running it does not miss a beat until you turn the car off and come back to it, and again the pumps not working.

    Really hoping its a quick fix as all you probably know it requires the subframe to removed to get at it.

    Any help or pondering would be much apprieated.

    Thanks
    Ant

  2. #2
    Status
    Offline
    badboysracing69's Avatar
    AOC Regular
    Join Date
    Nov 2006
    Posts
    228
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    The early pumps aren't very good, but if you can find another one then they can be removed and changed without touching the subframe. Do it all from the top
    Cheap Vaux mech at your service in Herts/cambs

  3. #3
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    as above - i changed mine 3 times

    if its the early TRW Generation 1 pump - basically has a slim round reservoir and a ribbed metal body then this is the one u have....very temperemental at times

    a fully remanufactured unit can be had for circa £220 with a 3yr warranty - this is the option i chose

    or ebay and take a chance on a 2nd hand one

    IF on the other hand u have a small tubby reservoir with a smooth metal base its the revised TRW Generation 2 pump - much better than the previous one.

    Theres also the Delphi pump which is a very bizarre angular shaped one.

    Only the Gen1 was a known fault across the range of early models but beware - dont get a Gen2 or Delphi and expect it to work on your steering rack cos it simply wont.

    It'll need a like for like replacement

    One thing I know that sometimes works is by removing the wiring harness that runs from pump to fusebox and replacing the entire harness with fresh wire - especially the earth lead..... but if ur doin this, u need to remove the pump from the car (lift out of top as said above - easy on the 8v too) so youd be better off replacing it with another one

    just remember to plug it into the fuse box before fitting, earth it and see if it runs

    HTH

  4. #4
    Status
    Offline
    ant46's Avatar
    AOC Newbie
    Join Date
    Sep 2006
    Posts
    35
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Lovley thanks guys,

    it sound like I have the generation one pump with all the problems. At least I know now though, would a new pump be ok on the org harness? At least I know I dont have to go at it from underneath.

    Thanks again!

Similar Threads

  1. Replies: 1
    Last Post: 12-01-2010, 16:22
  2. Power steering pump
    By Kim in forum Electrical
    Replies: 12
    Last Post: 10-11-2007, 21:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •