Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Left indicators not working

  
  1. #1
    Status
    Offline
    Deb's Avatar
    AOC Newbie
    Join Date
    Sep 2008
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Left indicators not working

    Please can anyone help. Doesnt seem to be the bulbs, dashboard indicators just click really fast when left indicator is selected. Where is the relay situated?

  2. #2
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    do ur hazards work?

    my initial suspicion is the actual indicator stalk....commonly causes weird goings on with lights and indicators

    surely sum1 more knowledgeable will be along shortly

    out of interest though - what mk/model/year is it?

  3. #3
    Status
    Offline
    Deb's Avatar
    AOC Newbie
    Join Date
    Sep 2008
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    sorry forgot to include this vital info - 1.7 CDTi sport 54 plate. Thanks for your reply

  4. #4
    Status
    Offline
    LEE69's Avatar
    AOC Obsessed
    Join Date
    Aug 2003
    Posts
    5,594
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Really fast indiactes bulbs gone put the hazard switch on and see if all 4 flash.

  5. #5
    Status
    Offline
    Moonman's Avatar
    AOC Obsessed
    Join Date
    Mar 2007
    Drives
    Astra J VXR
    Location
    Newport
    Posts
    3,010
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    Add Moonman on Facebook
    What Lee said m8. Rapid flashing indicators is usually a blown bulb in the system somewhere either the front, side or rear indicator.
    Summit White Astra J GTC VXR 2.0L Petrol Turbo (276 PS) with Aero Pack and 20's

  6. #6
    Status
    Offline
    Andy's Avatar
    AOC Obsessed
    Join Date
    Jan 2005
    Posts
    5,313
    Mentioned in
    5 Post(s)
    Quoted
    0 Post(s)
    hi,

    ive moved this to the electrical section for you (presumed its a mk4?)
    Drives - 08 Astra SRi XP 1.9CDTi 150

    Beer is living proof that God loves us and wants us to be happy.

  7. #7
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,743
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    As asked above do the left indicators work with the hazards?

    Would yours be the newer MK5 shape Astra?
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  8. #8
    Status
    Offline
    Da_Astra_Guy's Avatar
    AOC Regular
    Join Date
    Mar 2007
    Posts
    220
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Remember there is 6 indicator bulbs on moderen cars these days has either of the Side repeaters stopped working? if they aren't then id look at either the ind. switch or possibly the wiring to each bulb. Even a bit of resistance could cause what would look like a bulb failure.
    Former Astra: Mk3 1.4 K reg
    Current Astra: Mk4 1.4 V reg LS (The Half-Arsed Astra )

  9. #9
    Status
    Offline
    Deb's Avatar
    AOC Newbie
    Join Date
    Sep 2008
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks everyone for your replies, no its MK4 autosparks, and no left indicators worked when hazzards on

  10. #10
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,743
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    With no left indicators with the hazards on also it would suggest the indicator relay as you first thought. This is in the fuse box under the dash, large relay double the size of the others in the top right corner
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





Page 1 of 2 12 LastLast

Similar Threads

  1. indicators only working on the left! ?
    By leecavturbo in forum Electrical
    Replies: 2
    Last Post: 26-09-2010, 20:05
  2. Left indicators not working
    By Deb in forum Diesel Engines inc. Transmissions
    Replies: 1
    Last Post: 04-09-2008, 21:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •