Results 1 to 5 of 5

Thread: Z20LET misfire, any suggestions?

  
  1. #1
    Status
    Offline
    tox's Avatar
    AOC Newbie
    Join Date
    Jun 2007
    Posts
    11
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Z20LET misfire, any suggestions?

    Hi mates

    I have an Astra VXR-like from 2001, with the Z20LET turbo engine. From April till now the car hasn't been started due to a minor accident in the front (just the headlights and front bumper were affected). Now when i assembled it together, i had some problems with the engine, it started to hesitate until 2000 rpm then was fine, but at last the check engine light started to flicker then stayed on

    Today i went at the local Opel dealer and managed to put the tech2 on the car, it said Engine Cylinder 4 misfire. The specialist there told me that could be a reason that the car was not started for almost 5 months and told me to put some new fuel in the tank and try to go on the highway and keep it high revs . The worst case he told me, that the ignition coil pack might be faulty. And also the spark plugs, but as far as i know because i changed them i have NGK Iridium BCPR16ES (i read somewhere on this forum about those plugs and they have 7000 km of use)

    Do you have any other sugesstions ?

    Thank you

  2. #2
    Status
    Offline
    wywywywy's Avatar
    AOC Obsessed
    Join Date
    Sep 2005
    Posts
    1,478
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hi,

    I can't give you an answer but there are a few things to think about. When there is a misfire in a cylinder, there can only be two things - no spark or no fuel.

    No spark
    - Spark plugs? (Put OE ones back and try again? Is the gap correct?)
    - Leads? (Check for corrosion and carbon build-up at the contact points)
    - Coil pack?

    No fuel
    - Injector? (Is it blocked? Is power getting to it?)
    - Fuel? (Enough pressure to go to all cylinders? Any contamination? How about the fuel filter?)
    Astra Coupe Turbo Project Log KW var2, BK299, Apexi, HID, Angel, Leather Cobra, Phoenix Gold, GT/R2, Fluted, DV26D, Pre/Sports/Catback, CarPC, B&M, VXR Turbo, Tarox-10, Phase 3! Car is for sale!

  3. #3
    Status
    Offline
    tox's Avatar
    AOC Newbie
    Join Date
    Jun 2007
    Posts
    11
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i made some tests last night, put 98 octane fuel in it, some octane booster aditive and fuel injector cleaner and went on the highway. Now it works ok if you drive it normally, but it's hesitating when you rev it immediately. If you rev it slowly it works ok. My guess is that the injectors need cleaning, due to the fact that the car was not started a long time, and due to bad quality of fuel in my country, some residues built up on them. My guess is that the spark plugs are Ok, i don't think that they broke while standing, same goes for the coil pack. Could be also a problem that the AMM is very dirty ? (the car was stationary without the airbox due to the A/C pipes which were not put in place by the mechanics, they go under the left engine mounting not on top of it so the airbox wouldn't fit)

    can i clean it spraying with WD40 ?

    Thanks

  4. #4
    Status
    Offline
    tox's Avatar
    AOC Newbie
    Join Date
    Jun 2007
    Posts
    11
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I bought Denso spark plugs the equivalent of Bosch FLR8LDCU i'll try to change them. Don't think the coil pack is faulty, sometimes it works ok sometimes not, i believe it's a faulty spark plug. I hope is not the coil pack, it's about 280 E

  5. #5
    Status
    Offline
    gsi-jay's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    2,049
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    sounds like the spark is being blown out adjust your plug gap to .27mm
    courtney stage 3 zafira,Mitsubishi evo geek mapped to 389 and 470 lb of torque

Similar Threads

  1. Z20let misfire
    By Kwcoupe in forum Turbo Petrol Engines inc. Transmissions
    Replies: 13
    Last Post: 03-09-2014, 14:47
  2. Z20LET Misfire
    By Gary_Lawton in forum Turbo Petrol Engines inc. Transmissions
    Replies: 16
    Last Post: 23-12-2010, 00:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •