Results 1 to 3 of 3

Thread: knock sensor

  
  1. #1
    Status
    Offline
    alimighty's Avatar
    AOC Fanatic
    Join Date
    May 2008
    Posts
    428
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Unhappy knock sensor

    hi yall again
    In my last post about this i mention about the eml light staying on after replacing te ks with a new one. tryed the battery trick but with no luck so took it to garage yday and got the code cleared. i got 100yards up road and came bk on. The eml always lights up at around 20-25mph. So took it bk to garage ( got refund without asking for it ) and he said he aint a clue why it came back on.
    it can either be a dodgy ks or a fault in the wiring somewhere.

    any advice or info?

  2. #2
    Status
    Offline
    pavsid's Avatar
    AOC Newbie
    Join Date
    Apr 2008
    Posts
    31
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I had ks codes being brought up - usually something else causing it.

    What car have you got,have you tried the paperclip test to see if there are any other codes being brought up?

    When was the last service, timing belt or waterpump change?

  3. #3
    Status
    Offline
    techsteve's Avatar
    AOC Obsessed
    Join Date
    Feb 2006
    Posts
    1,046
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    From reading your earlier post it sounds like you have a form of misfire which will cause the knock sensor code to come up, you need to sort the misfire problem first, this should cure the knock sensor code
    HIGHDOWN Car Audio & Security
    Clifford, Genesis, Rockford, CDT Audio

Similar Threads

  1. Locating the Knock Sensor & Cam Sensor
    By MicKPM in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 4
    Last Post: 27-10-2004, 15:38

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •