Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: What problems to look for in a Z20LET

  
  1. #1
    Status
    Offline
    chr15g's Avatar
    AOC Fanatic
    Join Date
    Jun 2004
    Posts
    506
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    What problems to look for in a Z20LET

    as mentioned in the other post, im going to view an Astra Coupe Turbo next week,
    can anyone give me a few pointers on what things to look out for
    (to know if the cars been completely shagged or not!!)

    Apologies in advance if theres alreay a thread on this,
    which i highly suspect there will be!!

    Cheers guys.
    Chris

    2.0 Coupe Turbo
    (Now Dead........)

  2. #2
    Status
    Offline
    chr15astra's Avatar
    AOC Obsessed
    Join Date
    Oct 2007
    Posts
    1,588
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    smoke out the exhaust that not a good thing on start up and when boosting.

  3. #3
    Status
    Offline
    ZAF_GSI's Avatar
    AOC Obsessed
    Join Date
    Nov 2007
    Posts
    2,933
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Rocker cover gasket prone to go.(Leaky oil)
    PHASE 3 ON A SWITCH WIV A GARRETT

  4. #4
    Status
    Offline
    d dave's Avatar
    AOC Obsessed
    Join Date
    May 2003
    Location
    Edinburgh
    Posts
    11,579
    Mentioned in
    0 Post(s)
    Quoted
    5 Post(s)
    Add d dave on Facebook
    Make sure its been serviced regularly, timing belt, rollers and water pump have been changed at the relavant interval dependant on mileage.
    Scottish Member? Have a peep at our Region For tints or wraps Click Here!!

  5. #5
    Status
    Offline
    trez's Avatar
    AOC Fanatic
    Join Date
    Mar 2008
    Posts
    924
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by chr15g View Post
    as mentioned in the other post, im going to view an Astra Coupe Turbo next week,
    can anyone give me a few pointers on what things to look out for
    (to know if the cars been completely shagged or not!!)

    Apologies in advance if theres alreay a thread on this,
    which i highly suspect there will be!!

    Cheers guys.
    mate, i dont blame u for asking this on here...
    when i bought mine, i didnt know much about them, and i didnt even know bout this site...i had few problems with mine, and took me about 1 month and half to get it back on track...now im loving it...

    defo look for service history, timing belt change depending on mileage etc, water pump and another important bit, get down on the floor and check for any leaking oil...previous owners, i wouldnt be too worried bout it, as they are turbos, and can be expensive to run, so people tend to sell em...for example me, im in two minds bout selling as its rather expensive and im skint lol

    good luck mate
    Sapphire Black VxR Black Theme with a Touch of White, 3" Scorpion System, DapR springs, Rarb, JBI Tophat, FMIC & CDTI Conversion, Iridium Plugs, Full SMD in White...

  6. #6
    Status
    Offline
    chr15g's Avatar
    AOC Fanatic
    Join Date
    Jun 2004
    Posts
    506
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Dave,
    you working on friday??
    (fancy a road trip )
    lol

    Yeah i know there are loads of folk on here with the Z20LET,
    so its daft not to ask really!
    Chris

    2.0 Coupe Turbo
    (Now Dead........)

  7. #7
    Status
    Offline
    d dave's Avatar
    AOC Obsessed
    Join Date
    May 2003
    Location
    Edinburgh
    Posts
    11,579
    Mentioned in
    0 Post(s)
    Quoted
    5 Post(s)
    Add d dave on Facebook
    Fraid so Chris, where you off to? and when?
    Scottish Member? Have a peep at our Region For tints or wraps Click Here!!

  8. #8
    Status
    Offline
    chr15g's Avatar
    AOC Fanatic
    Join Date
    Jun 2004
    Posts
    506
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Test drove a couple of Coupe Turbo's at the weekend...
    One had a little bit of smoke on startup, nothing too drastic though..
    When i was pulling, there was alot of smoke till the car heated up, and through the rev range, there was a very noticable gap in power between certain RPM's.

    when i told the garage about it, they said that the Turbo Seal had a crack, and a replacement was due in (even showed me a reciept to prove this)

    This is thankfully NOT the one i'm going to go for, the car in question has a dump valve fitted, albeit not a very loud one.

    What does this ecxess of smoke, and lack of power actually mean?
    Is this the sign of a f***ed Turbo? or are they correct in saying its just the seal?

    I obviously ask , as when i do actually buy a Z20LET, i 'd rather know what to do incase something does go wrong!!!

    Thanks in advance...
    Chris

    2.0 Coupe Turbo
    (Now Dead........)

  9. #9
    Status
    Offline
    Coupe John's Avatar
    AOC Obsessed
    Join Date
    Aug 2007
    Drives
    Astra 1.8vvt X Pack
    Location
    Leeds
    Posts
    2,594
    Mentioned in
    17 Post(s)
    Quoted
    61 Post(s)
    Seal my arse, they would have to rebuild the turbo to fit it, cheaper to buy a new unit. Try find one which has had regular service records, or receipts to prove the oil changes have been done, most would have had new turbo's fit by now so check for this to, smoke from the exhaust is usually 80% of the time the turbo, other times is a simple kink in the breather pipes, the loss of power could be anything from a duff airflow meter to boost selonoids or a tired turbo.

  10. #10
    Status
    Offline
    chr15g's Avatar
    AOC Fanatic
    Join Date
    Jun 2004
    Posts
    506
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    this one did have full service history, with regular oil changes etc.
    this is why im confused as to what the problem could be, as it seems well maintained...
    Chris

    2.0 Coupe Turbo
    (Now Dead........)

Page 1 of 2 12 LastLast

Similar Threads

  1. z20let problems
    By givithard in forum Turbo Petrol Engines inc. Transmissions
    Replies: 6
    Last Post: 30-05-2014, 09:54
  2. gsi z20let problems
    By meanmatt in forum Turbo Petrol Engines inc. Transmissions
    Replies: 18
    Last Post: 06-04-2011, 19:51
  3. z20let problems
    By geoffsgsiturbo in forum Turbo Petrol Engines inc. Transmissions
    Replies: 12
    Last Post: 09-11-2008, 23:56

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •