Page 1 of 4 1234 LastLast
Results 1 to 10 of 35

Thread: Engine pinking 1.6 16v

  
  1. #1
    Status
    Offline
    sktr4lf's Avatar
    AOC Obsessed
    Join Date
    Dec 2007
    Posts
    1,349
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Engine pinking 1.6 16v

    Right guys after taking my car to the garage ive narrowed down the engine bay noise.

    cars a 2001 mk4 1.6 16v.

    mechanics called it engine pinking,does it at low revs when the engines under strain, ie. pulling away at junctions and driving up inclines. it matches the revs of the engine,and disappears once youve pulled away properly.

    seems to happen in lower gears rather than higher,and we also managed to get it to do it at idle by straining the engine.

    The mechanic is unsure, hes gonna plug it into a lappy when it goes for the MOT,but its weird, no EML is coming up or anything,and the car runs fine otherwise.

    He suspects it may be an ECU problem,that the ecu isnt giving the engine the right timings or something.

    so ,any other ideas/theories?

    im not sure if its a serious problem,but the noise is bugging the crap out of me!!

    thx


  2. #2
    Status
    Offline
    sktr4lf's Avatar
    AOC Obsessed
    Join Date
    Dec 2007
    Posts
    1,349
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    bump- no one has any ideas?


  3. #3
    Status
    Offline
    AndyH's Avatar
    Bit busy... be back soon!
    Join Date
    Jul 1971
    Drives
    Astra Coupe 2.2
    Posts
    300,024,286
    Mentioned in
    133 Post(s)
    Quoted
    30 Post(s)
    Follow AndyH On Twitter Add AndyH on Facebook Add AndyH on Google+
    Naffed knock sensor?
    Actively proving that post counts mean jack sh*t since 1971

  4. #4
    Status
    Offline
    scdavis's Avatar
    AOC Obsessed
    Join Date
    Apr 2008
    Posts
    3,284
    Mentioned in
    4 Post(s)
    Quoted
    11 Post(s)
    pinking is caused by cam timing out of align with the crank by either 1 tooth.
    its when the fuel is dumped in the chamber at the wrong time (very slightly).


    have u had a belt changed recently? or been putting it REALLY under strain in the low gears?

    id be doubtful if it throws up a fault code tho. ull probably notice that your consumption isnt getting any better either

    how many miles has the car done, and when was the last service?

  5. #5
    Status
    Offline
    sktr4lf's Avatar
    AOC Obsessed
    Join Date
    Dec 2007
    Posts
    1,349
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    53k,last serviced about 2000 miles ago. it had the timing belt done, im not sure if it was making this noise before then to be honest.

    is the knock sensor part of the ecu? or a seperate component?


  6. #6
    Status
    Offline
    scdavis's Avatar
    AOC Obsessed
    Join Date
    Apr 2008
    Posts
    3,284
    Mentioned in
    4 Post(s)
    Quoted
    11 Post(s)
    knock sensor is on the back of the block halfway up.

  7. #7
    Status
    Offline
    sktr4lf's Avatar
    AOC Obsessed
    Join Date
    Dec 2007
    Posts
    1,349
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    hmm,well id rather it was that thats jiggered than the ECU heh. cheap part to replace if it is that?


  8. #8
    Status
    Offline
    scdavis's Avatar
    AOC Obsessed
    Join Date
    Apr 2008
    Posts
    3,284
    Mentioned in
    4 Post(s)
    Quoted
    11 Post(s)
    erm pass, could be £15 or so, honestly dont know.

    if it is the timing thats caused it then take it back to the garage that did the belt and make them check it. they might not have tightened up the tensioner properly, hence it slipping down a tooth or so.


    tbh if its not really mis firing or playing up then it wont do damage as todays engines that using direct injection can handle the belt being misaligned by a bit as the injection system is controlled by the ECU

  9. #9
    Status
    Offline
    sktr4lf's Avatar
    AOC Obsessed
    Join Date
    Dec 2007
    Posts
    1,349
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    the car drives fine besides, but the noise drives me nuts as i hear it at every junction/roundabout etc when i pull away.

    just want to be sure its nothing more serious and end up having to shell out loads further down the line cos i didnt bother getting it sorted now.


  10. #10
    Status
    Offline
    MarkyG's Avatar
    AOC Obsessed
    Join Date
    Jul 2006
    Posts
    1,442
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I'd stop driving it matey.

    You changed your spark plugs to aftermarket oneS?

Page 1 of 4 1234 LastLast

Similar Threads

  1. 1.7DTi ECO4 Engine Pinking ??
    By jjh2588 in forum Diesel Engines inc. Transmissions
    Replies: 15
    Last Post: 22-12-2012, 00:18
  2. Pinking
    By Lisajk in forum Diesel Engines inc. Transmissions
    Replies: 9
    Last Post: 09-03-2009, 14:45
  3. Still pinking?
    By SXIScot in forum Chassis
    Replies: 11
    Last Post: 19-09-2004, 13:25

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •