Results 1 to 4 of 4

Thread: What have they done to my GSI

  
  1. #1
    Status
    Offline
    markiehill's Avatar
    AOC Newbie
    Join Date
    Feb 2007
    Posts
    39
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Question What have they done to my GSI

    I had a problem with my turbo , i.e. it was totally dead. Managed to source a turbo off Ebay which has done 20K. It was fitted yesterday....

    The turbo is boosting, however when it does there is a squeal for a second and then everything is fine.

    The garage say that because they do not have the tech, the waste gate sensor needs to be set up on the turbo and that is what is causing the noise.

    Is this true, have they damaged the bearings of fitting it ??

    Mark
    Black Zafira GSI 52 plate.
    Black Merc C230K Class Sports Coupe 53 plate

  2. #2
    Status
    Offline
    gsi-jay's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    2,049
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    have you got a boost gauge if so wot is it boosting at as that wil tell you if maste gate is set correct if not there should be around 6 threads at bottom of the actuator roughly 6 mm
    courtney stage 3 zafira,Mitsubishi evo geek mapped to 389 and 470 lb of torque

  3. #3
    Status
    Offline
    markiehill's Avatar
    AOC Newbie
    Join Date
    Feb 2007
    Posts
    39
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i dont have a boost gauge, however the squealing has stopped, perhaps just needed to get some oil around it properly who knows.

    It know drives normally however the boost comes in waves, so feels like something needs adjusting.

    I will try checking the thread.

    mark
    Black Zafira GSI 52 plate.
    Black Merc C230K Class Sports Coupe 53 plate

  4. #4
    Status
    Offline
    Coupe John's Avatar
    AOC Obsessed
    Join Date
    Aug 2007
    Drives
    Astra 1.9 cdti xpack
    Location
    Leeds
    Posts
    2,593
    Mentioned in
    17 Post(s)
    Quoted
    61 Post(s)
    As said check your actuator, ive had a right pain trying to get mine right but my god what a difference when its set up well try around 5mm first as I found 6 is to much.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •