Results 1 to 10 of 10

Thread: coupe turbo accelerates on its own???

  
  1. #1
    Status
    Offline
    k.a.r.l's Avatar
    AOC Obsessed
    Join Date
    Jun 2008
    Posts
    1,986
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    coupe turbo accelerates on its own???

    please help as this is pretty scary as it just done it with the engine cold i had to dip the clutch but it just revved to the limiter and stayed there a couple of seconds then backed of. its got a mind of its own? pls help 1st time it happened it threw on the t/c and abs lights

  2. #2
    Status
    Offline
    dannysport18's Avatar
    AOC Obsessed
    Join Date
    Sep 2003
    Posts
    35,241
    Mentioned in
    7 Post(s)
    Quoted
    7 Post(s)
    when its cold it will rev a bit on its own
    get it pluged into tech2 to see what its doing

  3. #3
    Status
    Offline
    k.a.r.l's Avatar
    AOC Obsessed
    Join Date
    Jun 2008
    Posts
    1,986
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    def not an idle prob but yes come to think of it it has only done this when the engine is cold/warmish tech 2 me thinks

  4. #4
    Status
    Offline
    gsi-jay's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    2,049
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    sounds like a wireing problem if went up to rev limiter either the pedal end or the motor on the throtle body
    courtney stage 3 zafira,Mitsubishi evo geek mapped to 389 and 470 lb of torque

  5. #5
    Status
    Offline
    kg_turbo's Avatar
    AOC Obsessed
    Join Date
    Dec 2005
    Posts
    1,268
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    My old one did this and it was the throtle body that was knackered
    Zaffy VXR on the beat

  6. #6
    Status
    Offline
    sriturbo's Avatar
    the man in the boat
    Join Date
    Jul 2006
    Posts
    1,354
    Mentioned in
    1 Post(s)
    Quoted
    1 Post(s)
    Quote Originally Posted by kg_turbo View Post
    My old one did this and it was the throtle body that was knackered

    i have one for sale just now.....

    http://www.astraownersclub.com/vb/sh...52#post1419352

  7. #7
    Status
    Offline
    k.a.r.l's Avatar
    AOC Obsessed
    Join Date
    Jun 2008
    Posts
    1,986
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    right this is only happening when cold it does it 3-4 times then nothing when the engine warms up

  8. #8
    Status
    Offline
    Coupe John's Avatar
    AOC Obsessed
    Join Date
    Aug 2007
    Drives
    Astra 1.8vvt X Pack
    Location
    Leeds
    Posts
    2,594
    Mentioned in
    17 Post(s)
    Quoted
    61 Post(s)
    Quote Originally Posted by k.a.r.l View Post
    def not an idle prob but yes come to think of it it has only done this when the engine is cold/warmish tech 2 me thinks

    Poor turbo when engine is cold sounds like the stepper motor in the throttle body is at fault, or sticking.

  9. #9
    Status
    Offline
    tommo69tommo's Avatar
    AOC Regular
    Join Date
    Nov 2007
    Posts
    110
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i have this problem with mine only happens about twice a week when i change gear the revs shoot up about 1000rpm or if i take foot off accelerator it speeds up for a couple of seconds then dies off i was told it was the stepper motor and was advised to take off throttle body and give it a good spray/clean with carb cleaner

  10. #10
    Status
    Offline
    k.a.r.l's Avatar
    AOC Obsessed
    Join Date
    Jun 2008
    Posts
    1,986
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    ok will try that then thanks all

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •