Results 1 to 2 of 2

Thread: indicator, brake light not working

  
  1. #1
    Status
    Offline
    nishweth's Avatar
    AOC Newbie
    Join Date
    Jan 2008
    Posts
    20
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    indicator, brake light not working

    Hi i am having mk3 opel astra. The problem is that left side rear indicator and right brake light is not working. I have checked and changed the bulbs and also checked the holders but is not working. What could be the problem,is it cud be the wiring harness.

  2. #2
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,745
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    This has to be a bulb, the holder or wiring problem as those 2 items are too random to be linked.

    Check for corrosion on the bulb holders and also if you can get access to a multimeter check for a live at the holders for brake lights (black/yellow) and indicators (black/green one side and black/white the other)
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





Similar Threads

  1. brake light isn't working :(
    By jyeaman91 in forum Electrical
    Replies: 7
    Last Post: 25-09-2013, 21:52
  2. One brake light not working ... why?!
    By alexm in forum Electrical
    Replies: 8
    Last Post: 30-07-2009, 19:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •