Results 1 to 8 of 8

Thread: Engine management light and coolant light?? Help :(??

  
  1. #1
    Status
    Offline
    slowlanepsycho's Avatar
    AOC Newbie
    Join Date
    Nov 2007
    Posts
    54
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Engine management light and coolant light?? Help :(??

    Right guys just started up me astra 1.6 8V and it spluttered when starting and the engine management light comes on also the coolant light come on. And the coolant fan kicked in straight away and stayed on all the way to me mateís house?? I checked the coolant levels they were fine... also the engine temp needle did not move from cold?? What could be wrong?

    Mate of mine said it could be coolant temp sensor??

    But I donít know the credibility of his suggestion as he has never owned an Astra??

    If it is coolant temp sensor where is it located on the engine picture would be extremely useful as Iím a newbie when it come to this engine

    Thank you
    1999 T plate 1.6i 8v Astra Club (X16SZR engine)

  2. #2
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    CTS is on the back of the inlet manifold - look behind where the alternator is and youll see a harness leading to a plug in the rear of the inlet.

    5min job to replace and about 10 quid to purchase.

    usually CTS if it runs fine one min then when it warms up its a git to start again...basically ECU thinks the engine is cold (when its actually warm due to knackered CTS) so supplies more fuel therefore flooding the engine etc...

    worth a shot for the cost of the part and it is a known troublesome part.

    whilst ur doin that tho - clean the throttle body, EGR & ICV with some carb cleaner (about £3 from a local motor factors) will help the runnin of the car no end.

    Id say the lack of movement in the guage is more likely a knackered thermostat - luckily on the SZR its cheap as chips

    why not do the paperclip test seeing as the EML is on..... do a search for "paperclip" if u aint got a clue what im on about

  3. #3
    Status
    Offline
    slowlanepsycho's Avatar
    AOC Newbie
    Join Date
    Nov 2007
    Posts
    54
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    right

    Update called RAC and he plugged in diagnostics and he come up with

    Fault code P0115

    Coolant Temp Sensor

    (Can I get this from Halfords as I need it ASAP due to needing the car tomorrow on a long journey?)
    1999 T plate 1.6i 8v Astra Club (X16SZR engine)

  4. #4
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    very much doubt it - either Vauxhall or local motor factors on same day delivery is ur only real option

    ebay if u could wait which u cant....

    if u have a large vauxhall near u with a plentiful parts department then quote part number 90541937 and see if ur in luck

  5. #5
    Status
    Offline
    slowlanepsycho's Avatar
    AOC Newbie
    Join Date
    Nov 2007
    Posts
    54
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    ... reset

    right ok i have fitted in the new coolent temp sensor how do i now reset the fault code on ECU.... Disconnecting the battery for 15mins??????


    thankyou
    1999 T plate 1.6i 8v Astra Club (X16SZR engine)

  6. #6
    Status
    Offline
    slowlanepsycho's Avatar
    AOC Newbie
    Join Date
    Nov 2007
    Posts
    54
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Unhappy Update?????

    right I have changed the coolant temp sensor and still the same thing... engine management light comes on and rad light comes on... also fans start spinning immediately... however I have noted that if I pull out the wire from the back of the coolant temp sensor then everything runs ok but with the wire attached at the back of coolant temperature sensor the warning lights come up with the fans spinning Iím completely stumped now please help??? ..

    thank you
    1999 T plate 1.6i 8v Astra Club (X16SZR engine)

  7. #7
    Status
    Offline
    slowlanepsycho's Avatar
    AOC Newbie
    Join Date
    Nov 2007
    Posts
    54
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    update

    sent the car to garage to let them look at it as i dont know what wrong the car is missfiring and running rich.... see what they come up with??
    1999 T plate 1.6i 8v Astra Club (X16SZR engine)

  8. #8
    Status
    Offline
    Fastra's Avatar
    AOC Fanatic
    Join Date
    May 2003
    Posts
    568
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by slowlanepsycho View Post
    sent the car to garage to let them look at it as i dont know what wrong the car is missfiring and running rich.... see what they come up with??

    Hi mate,

    what was the outcome of this?
    I've got something similar.
    ... indicators do not give you right of way!!!

Similar Threads

  1. Replies: 39
    Last Post: 13-08-2010, 16:21
  2. Replies: 2
    Last Post: 31-08-2009, 21:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •