Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Faulty alternator, no battery light.

  
  1. #1
    Status
    Offline
    blingblingbob's Avatar
    AOC Newbie
    Join Date
    May 2008
    Posts
    13
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Faulty alternator, no battery light.

    I think my alternator has had the volatage regulator die. It no longer charges the battery and if I charge it over night, it runs sweet for one day. Tested the battery in the car fully charged its at 14.2 Volts, reving the engine at 3000rpm the volts just continue to fall.

    When the car is off and turn the key to the on postion all the lights come on except the battery light.

    I read some were that when the regulator goes it blows the battery light and that once the battery light is gone even with a fixed alternator it wont charge with out the light working.

    My question is who do I replace the battery light? It looks like an LED in the circuit board. How do I get to it, do I just pull the needles off? How do I know I've put the needles back in the right place, etc?

    Has anyone got an article on this?

  2. #2
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,745
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    Welcome mate

    Have you checked the alternators plugged in and none of the wires are snapped around it?
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  3. #3
    Status
    Offline
    blingblingbob's Avatar
    AOC Newbie
    Join Date
    May 2008
    Posts
    13
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Yeah the wires seemed fine, one big earth wire and one plug, which looks like only one wire.

    If that battery light is blown am I screwed.

    Thanks for the welcome, I wish I'd been here earlier, I just did the derestriction of the air box, we dont have Vectra C's in Australia so a mate is going to plastic weld me up a monster intake pipe. And when the car is running that pre-cat is gone!

  4. #4
    Status
    Offline
    blingblingbob's Avatar
    AOC Newbie
    Join Date
    May 2008
    Posts
    13
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    New regulator on the way, it was differently faulty. Still not sure about dash light. Auto electrican thinks it should be ok.

  5. #5
    Status
    Offline
    Mark T's Avatar
    AOC Obsessed
    Join Date
    Feb 2006
    Posts
    1,934
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    when the regulator over charges, the bulb often blows.

    The alternator won't normally charge with a blown bulb, so I'd replace that first unless you noticed it come on and get really bright before going out.
    How Tos . Parts For Sale
    The two most life changing experiences you'll ever have. Finding Jesus, and having a baby.

  6. #6
    Status
    Offline
    blingblingbob's Avatar
    AOC Newbie
    Join Date
    May 2008
    Posts
    13
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Replaced the voltage regulator, battery light is fine. Only the car wont start now.

    Check engine light was flashing. Engine was turning over fine. Battery may not be fully charged.

    There are all sorts of clicking noises coming from under the bonnet (like solenoid noises)

    Could a flat battery in the key cause these starting issues? Or just the remote central locking? Battery in key has now been replaced, giving the car battery another couple of hours on the charger.

  7. #7
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,745
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    Remote battery is only for the remote locking

    Flashing EML points towards a immobilisation problem, have you had the key apart since you last started it? You may have lost the black transponder chip out of it.

    Do you have a spare key you can try?
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  8. #8
    Status
    Offline
    blingblingbob's Avatar
    AOC Newbie
    Join Date
    May 2008
    Posts
    13
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I have another key but I need to what for the lady to come home, this key was causing grief just before the alternator died, I put it down to the battery in the key, maybe I was wrong. I only opened it for the first just before on the table I dont think I lost any thing, but I think she might have got it wet a short while back.

    Will try again.

  9. #9
    Status
    Offline
    blingblingbob's Avatar
    AOC Newbie
    Join Date
    May 2008
    Posts
    13
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Used the second key, fixed.

    Engine did idle funny but all seems good.

    Turns out my wife had stood on the lanyard she has on her keys whilst it was in the ignitoin and broke the key in half. She put it back together and had been having grief since.

    I couldnt see the black transponder in the old key does any one have a picture of what I'm looking for?

  10. #10
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,745
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    No pictures but the part is very small, probbaly only 7mm, 5mm, 3mm in size
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





Page 1 of 2 12 LastLast

Similar Threads

  1. battery light with new alternator
    By seanm10 in forum Astra Discussion & Chat
    Replies: 0
    Last Post: 19-08-2013, 23:01
  2. faulty battery / alternator?
    By Scott D in forum Electrical
    Replies: 6
    Last Post: 28-08-2009, 20:18
  3. Battery light still comes on after new alternator??
    By andyajc1912 in forum Electrical
    Replies: 5
    Last Post: 21-02-2009, 19:42

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •