Results 1 to 3 of 3

Thread: help brake light circuit fault

  
  1. #1
    Status
    Offline
    wurzil's Avatar
    AOC Newbie
    Join Date
    Apr 2008
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Angry help brake light circuit fault

    hi my first post hope someone can help. i seem to have developed a fault on my brake light circuit the fuse keeps blowing so have no brake or indicator lights. this problem seems to come and go at first i thought it was the bulbs but i replaced them and it worked fine for a week then started blowing again and all bulbs are fine. have checked all visible earths and they seem to be ok also have checked the brake light switch and that seems to be fine. anybody got any suggestions

    cheers
    steve

  2. #2
    Status
    Offline
    Coo's Avatar
    Banned
    Join Date
    May 2003
    Posts
    25,105
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Do you have the correct bulbs in ?
    And are they the right way round ?
    One of the bulbs has offset pins, so if you put it in 180degrees the wrong way it could cause problems...

    Also check the contacts for the bulbs...try and clean them up as best you can ..

    can't think of much else just now ....

  3. #3
    Status
    Offline
    jalfrezigazee's Avatar
    AOC Obsessed
    Join Date
    Aug 2006
    Posts
    3,102
    Mentioned in
    1 Post(s)
    Quoted
    0 Post(s)
    wait until the fault is happening all the time then disconnect brake light switch, indicator switch, indicator relay and remove the bulbs. A simple ohms meter test on the cables will find which cable is going to earth. Quite a hefty job but one you need to do. Sounds to me like you have a cable chafed against the bodywork. Can't see it being bulb related as the indicator and brakes are different bulbs and circuits. The other thing that just popped into mind is has the car had a towbar removed or fitted and the problem lie in the mess of cabling
    Be Happy


Similar Threads

  1. Brake light fault?
    By alib in forum Electrical
    Replies: 9
    Last Post: 16-01-2012, 20:07
  2. brake light fault.....
    By philchrome in forum Electrical
    Replies: 1
    Last Post: 21-12-2010, 20:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •