Results 1 to 9 of 9

Thread: help with a slight problem(light on dash)

  
  1. #1
    Status
    Offline
    smarty-turbo's Avatar
    AOC Fanatic
    Join Date
    Dec 2007
    Posts
    336
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Unhappy help with a slight problem(light on dash)

    few days ago my rad started leakin on my mk4 coupe turbo 2003 plate. so i went ordered a new rad and striped my front end down and fitted new one in the process i thought i would remove the air con rad and pipes no problem removed them and refitted intercooler and then started the car and now my fan is constant on and the light on the dash has come on that looks like a rad and fan on it.how do i get my fan workin properly only on when engine gets to right temp and light to go off??????????

    the reason why i removed the air con is because i have a forge front mount to be fitted

    can someone tell me how to solve the problem thanks

  2. #2
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,745
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    Welcome mate

    It could be that you haven't plugged back in a pressure sensor for the AC, double check everything again

    Obviously the AC will need a regass now as well
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  3. #3
    Status
    Offline
    chrismk4's Avatar
    AOC Regular
    Join Date
    Feb 2008
    Posts
    111
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    my does the exact same
    and ive found no solution yet!!??
    mk4 1.6 18" x 7.5" mania wheels, 40/40 mm PI shocks, black halo LED angel eyes, front irmscher grille, vectra c air intake, k&n filter, peco exhaust

  4. #4
    Status
    Offline
    Ruperts Trooper's Avatar
    AOC Obsessed
    Join Date
    Dec 2005
    Posts
    1,471
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    If you've removed the air-con "permanently" you're confusing the cooling module (a microprocessor) which controls the fan(s).

    Re-fitting the air-con and re-gassing it will cure the problem - but that's not what you want to hear !!
    Maintains:- Vectra Design 1.9CDTi
    Drives :- Hyundai Santa Fe


  5. #5
    Status
    Offline
    smarty-turbo's Avatar
    AOC Fanatic
    Join Date
    Dec 2007
    Posts
    336
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    yes i want to remove it permently if i fit it back my new forge front mount won't fit, is there a microprocesser i can get to solve it???????

    so basically i got to stick with fan constant on because i have removed air con system???

  6. #6
    Status
    Offline
    smarty-turbo's Avatar
    AOC Fanatic
    Join Date
    Dec 2007
    Posts
    336
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    if thats the case how don't astras without air con there fans work normally?????? can i get a microprocesser off one of them and fit it???? and happy days then

  7. #7
    Status
    Offline
    chrismk4's Avatar
    AOC Regular
    Join Date
    Feb 2008
    Posts
    111
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    god nos its a tricky one isnt it...
    some one must have an idea or solution???
    i've just checked my coolant control module and its F&*%'d
    full of water! so i think that that maybe my problem..
    just ordered a new one so hopefully this will cuire it!
    and to answer your question i wouldnt know wether one off another astra without aircon would work, maybe it would???
    mk4 1.6 18" x 7.5" mania wheels, 40/40 mm PI shocks, black halo LED angel eyes, front irmscher grille, vectra c air intake, k&n filter, peco exhaust

  8. #8
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,745
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    Ok didn't realise that you had removed the AC but not refitted it, glad someone read the question properally......

    I can only think of getting onto vauxhall and trying to order up a new coolant control module for a car without AC although you may then find the wirings different

    Other than that remove the whole lot (box included) and rewire the temp sensor through a relay so that the fan only comes on when needed
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  9. #9
    Status
    Offline
    smarty-turbo's Avatar
    AOC Fanatic
    Join Date
    Dec 2007
    Posts
    336
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    just had a potch with it this morning to solve the problem about the fan constant on ware the sensor plugs into a/c pump there are 2 nuts undo the top 1 and leave that connected it just tells ecu that it is in place,

    the light on the dash i think is sum sort of sensor that tells you gas is low in a/c system and stays on im not sure but if ne one has ne info pls let me knw thanks matt

Similar Threads

  1. Dash light, sidelights and rear fog light problem
    By boblopez in forum Electrical
    Replies: 0
    Last Post: 07-12-2010, 10:53
  2. Replies: 36
    Last Post: 13-06-2010, 15:33
  3. Dash Light Problem
    By Shug in forum Electrical
    Replies: 1
    Last Post: 07-09-2008, 22:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •