Results 1 to 6 of 6

Thread: Erratic rev's from cold

  
  1. #1
    Status
    Offline
    Norseman's Avatar
    AOC Newbie
    Join Date
    Mar 2008
    Posts
    12
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Erratic rev's from cold

    Hi Guy's,

    I'm new here but loving the site already, so much information to take in!

    To cut a long story short I have always had problems with erratic rev's in my car (Mk 4 astra 1.4) most of the problems were solved when I got my timing belt done a couple of months ago but lately I seem to be having some more problems.

    In particular when I first start driving the car either in the mornings or after work the car will chug like crazy in 2nd gear at anything below 3k rpm... and then when I come to a stop and press the clutch in fully the car rev's itself up to around 2.5-3k rpm and then drops back down to normal.

    This happens every time I stop the car unless I have been driving for a few minutes and everything is warmed up. Any ideas what it could possibly be? I am going to try (weather permitting) to clean the EGR valve and ICV tomorrow using the guides on the site.. this will be my first attempt at anything like that so hope it goes well! My engine management light has also been on constantly for the past couple of weeks but I havnt noticed that affecting performance in any way.

    My plan was to try clean the ICV and EGR tomorrow and check my pretensioners (yes that light is on too ) then bring it to my local dealer to have tech2 turn off the lights and see if they come back on.

    Anywho if I don't stop now this will become the life history of my car... any advice?

    Thanks!

  2. #2
    Status
    Offline
    scott_sxi's Avatar
    AOC Fanatic
    Join Date
    Sep 2007
    Posts
    868
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    my car makes a weaird noise when starting from cold and as soon as its warmed up its then fine... not sure what this is though.... i assumed they all did it and its just because it cold..

  3. #3
    Status
    Offline
    Toms1989's Avatar
    Soft Top VTEC :)
    Join Date
    Dec 2007
    Posts
    11,356
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    If its chugging aswell, Have a look at the throttle body, mine was caked up with oil and grease and used to stutter a lot, when I cleaned it it was a lot better
    FULL Black Leather Heated coupe interior for sale! £200!!!
    Click Here

  4. #4
    Status
    Offline
    16v ecotec's Avatar
    AOC Regular
    Join Date
    Feb 2006
    Posts
    96
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Norseman View Post
    Hi Guy's,

    I'm new here but loving the site already, so much information to take in!

    To cut a long story short I have always had problems with erratic rev's in my car (Mk 4 astra 1.4) most of the problems were solved when I got my timing belt done a couple of months ago but lately I seem to be having some more problems.

    In particular when I first start driving the car either in the mornings or after work the car will chug like crazy in 2nd gear at anything below 3k rpm... and then when I come to a stop and press the clutch in fully the car rev's itself up to around 2.5-3k rpm and then drops back down to normal.

    This happens every time I stop the car unless I have been driving for a few minutes and everything is warmed up. Any ideas what it could possibly be? I am going to try (weather permitting) to clean the EGR valve and ICV tomorrow using the guides on the site.. this will be my first attempt at anything like that so hope it goes well! My engine management light has also been on constantly for the past couple of weeks but I havnt noticed that affecting performance in any way.

    My plan was to try clean the ICV and EGR tomorrow and check my pretensioners (yes that light is on too ) then bring it to my local dealer to have tech2 turn off the lights and see if they come back on.

    Anywho if I don't stop now this will become the life history of my car... any advice?

    Thanks!
    i had a zafira in work the other week with high idle and all it needed was a flash programme with the upgraded softwear

    if its the egr valve causing the engine management light to come on once its cleanes and moving well the light should go off, but the trouble code will still be stored in the ecu. but this shouldn't cause any problems.

  5. #5
    Status
    Offline
    Skell18's Avatar
    AOC Obsessed
    Join Date
    Nov 2007
    Posts
    1,159
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I cleaned my throttle body yesterday and it helped alot, it just fires upto about 2.5k rpm when i 1st start it up then settles down and its fine and normal.

  6. #6
    Status
    Offline
    Oddjob's Avatar
    AOC Obsessed
    Join Date
    May 2003
    Posts
    5,213
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    It's probably the EGR valve, there is no ICV on this engine BTW.

    Fried of mine had a similar problem on his 2.2 but his was the reverse of yours, fine when cold, crap when warm. Turned out to be the EGR valve, he blanked it off in the end and the cars been great ever since. If you do blank it off leave it wired up but taped up inside the engine bay.
    52 Astra G 1.8, 18" Mille Miglia alloys, 325mm Brembo 4 pot conversion, Coupe leather interior, Raid strut brace, Whiteline rear ARB, Irmscher bits (skirts, Carbon steering wheel, Bonnet extension, M3 mirrors, boot & roof spoiler), Reiger Rear Diffuser & Front Bumper, Koni Adj. dampers, 35/30 Vogtland springs, Duplex quad exit ASCAR stainless exhaust.

Similar Threads

  1. astra 1.7cdti erratic idle after cold start
    By craigie1976 in forum Diesel Engines inc. Transmissions
    Replies: 1
    Last Post: 07-04-2013, 22:15
  2. Rev's
    By kevincox1987 in forum Astra Discussion & Chat
    Replies: 7
    Last Post: 10-10-2011, 20:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •